tools/bison: Update to 3.3.2
[openwrt/staging/stintel.git] / tools / bison / Makefile
index b7fdf254a27b10bf85e9ae4a07b9bb62866cefc1..2dcbe617af34b04fb5151edce89bf2179aecb7ff 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2008-2012 OpenWrt.org
+#
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,20 +7,26 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bison
-PKG_VERSION:=2.5
+PKG_VERSION:=3.3.2
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_MD5SUM:=9dba20116b13fc61a0846b0058fbe004
-PKG_CAT:=bzcat
+PKG_HASH:=039ee45b61d95e5003e7e8376f9080001b4066ff357bde271b7faace53b9d804
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_LDFLAGS += -static
+HOST_CONFIGURE_ARGS += --enable-threads=pth
 
 define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
        $(call Host/Clean/Default)
 endef
 
+define Host/Install
+       $(call Host/Install/Default)
+       $(INSTALL_BIN) ./scripts/yacc $(STAGING_DIR_HOST)/bin/yacc
+endef
+
 $(eval $(call HostBuild))