tools/patchelf: update to 0.18.0
[openwrt/staging/dedeckeh.git] / tools / automake / Makefile
index 0eea1019830052a94b86b97cf18ab5a408d762b4..4c1e5758cbcbcea53e5dcb76d91990db611759f6 100644 (file)
@@ -7,16 +7,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=automake
-PKG_VERSION:=1.15
+PKG_CPE_ID:=cpe:/a:gnu:automake
+PKG_VERSION:=1.16.5
+PKG_API_VERSION:=$(word 2,$(subst ., ,$(PKG_VERSION)))
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/automake
-PKG_MD5SUM:=9a1ddb0e053474d9d1105cfe39b0c48d
+PKG_HASH:=f01d58cd6d9d77fbdca9eb4bbd5ead1988228fdb73d6f7a201f5f8d6b118b469
 
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CONFIGURE_ARGS += \
-       --datarootdir=$(STAGING_DIR_HOST)/share \
        --disable-silent-rules
 
 HOST_CONFIGURE_VARS += \
@@ -24,27 +25,29 @@ HOST_CONFIGURE_VARS += \
        am_cv_prog_PERL_ithreads=no
 
 define Host/Configure
-       (cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) STAGING_DIR="" ./bootstrap.sh)
+       (cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) STAGING_DIR_HOST="" ./bootstrap)
        $(call Host/Configure/Default)
 endef
 
 define Host/Install
        # remove old automake resources to avoid version conflicts
-       rm -rf $(STAGING_DIR_HOST)/share/aclocal-[0-9]*
-       rm -rf $(STAGING_DIR_HOST)/share/automake-[0-9]*
-       $(MAKE) -C $(HOST_BUILD_DIR) install
+       $(call Host/Uninstall)
+       $(call Host/Compile/Default,install)
        mv $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal.real
        $(INSTALL_BIN) ./files/aclocal $(STAGING_DIR_HOST)/bin
-       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
-       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
-       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
-       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.6
-       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.15
+       ( \
+               api=$(PKG_API_VERSION); \
+               while [ "$$$$api" -ge 11 ]; do \
+                       ln -sf aclocal "$(STAGING_DIR_HOST)/bin/aclocal-1.$$$$api"; \
+                       api=$$$$(($$$$api - 1)); \
+               done; \
+       )
 endef
 
-define Host/Clean
-       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
-       $(call Host/Clean/Default)
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
+       rm -rf $(STAGING_DIR_HOST)/share/aclocal-[0-9]*
+       rm -rf $(STAGING_DIR_HOST)/share/automake-[0-9]*
 endef
 
 $(eval $(call HostBuild))