x86: Add kmod-dwmac-intel
[openwrt/staging/hauke.git] / tools / autoconf / Makefile
index f5d22c3ff85fa04c3b3e88dc19732ed4d13df96f..a1ce158031245728ace3d6cc745756eff24ab128 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,31 +7,25 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=autoconf
-PKG_VERSION:=2.68
+PKG_VERSION:=2.71
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/autoconf
-PKG_MD5SUM:=864d785215aa60d627c91fcb21b05b07
+PKG_HASH:=f14c83cfebcc9427f2c3cea7258bd90df972d92eb26752da4ddad81c87a0faa4
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Host/Configure
-       $(call Host/Configure/Default,\
-               --datarootdir=$(STAGING_DIR_HOST)/share \
-       )
-endef
+HOST_CONFIGURE_VARS += \
+       EMACS="no" \
+       PERL="/usr/bin/env perl"
 
 define Host/Compile
-       export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR)
-endef
-
-define Host/Install
-       export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) install
+       -$(call Host/Compile/Default,--touch install-man1) # disable building of man pages
+       $(call Host/Compile/Default)
 endef
 
-define Host/Clean
-       -export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) uninstall
-       $(call Host/Clean/Default)
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
 endef
 
 $(eval $(call HostBuild))