x86: Add kmod-dwmac-intel
[openwrt/staging/hauke.git] / tools / autoconf / Makefile
index c45855c03d5a877ee6523ab91cd2a6501b60a2e0..a1ce158031245728ace3d6cc745756eff24ab128 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -7,31 +7,25 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=autoconf
-PKG_VERSION:=2.69
+PKG_VERSION:=2.71
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/autoconf
-PKG_MD5SUM:=50f97f4159805e374639a73e2636f22e
+PKG_HASH:=f14c83cfebcc9427f2c3cea7258bd90df972d92eb26752da4ddad81c87a0faa4
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_CONFIGURE_ARGS += \
-       --datarootdir=$(STAGING_DIR_HOST)/share
-
 HOST_CONFIGURE_VARS += \
+       EMACS="no" \
        PERL="/usr/bin/env perl"
 
 define Host/Compile
-       export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR)
-endef
-
-define Host/Install
-       export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) install
+       -$(call Host/Compile/Default,--touch install-man1) # disable building of man pages
+       $(call Host/Compile/Default)
 endef
 
-define Host/Clean
-       -export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) uninstall
-       $(call Host/Clean/Default)
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
 endef
 
 $(eval $(call HostBuild))