glibc: update to 2.34 HEAD
[openwrt/staging/nbd.git] / toolchain / glibc / common.mk
index ad4b3243745d34403d3024924a2a9c0e65317038..51d13c457ead73829b877327a2895fd41453cd63 100644 (file)
@@ -7,13 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=glibc
-PKG_VERSION:=2.31
+PKG_VERSION:=2.34
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=4bc9918c998085800ecf5bbb3c863e66ea6252a0
-PKG_MIRROR_HASH:=51877ffff6819b5ccc004a842de755c6c203996d673d94d7013927712e252c17
+PKG_SOURCE_VERSION:=72123e1b56f53f9205bb105f8a62d0869b837b22
+PKG_MIRROR_HASH:=934ec7067d41da0b76b8f29a1cd03b10ba9d98c2f761f7b32f8595e59ac2b428
 PKG_SOURCE_URL:=https://sourceware.org/git/glibc.git
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
 
@@ -63,7 +63,8 @@ GLIBC_CONFIGURE:= \
                --$(if $(CONFIG_SOFT_FLOAT),without,with)-fp \
                  $(if $(CONFIG_PKG_CC_STACKPROTECTOR_REGULAR),--enable-stack-protector=yes) \
                  $(if $(CONFIG_PKG_CC_STACKPROTECTOR_STRONG),--enable-stack-protector=strong) \
-               --enable-kernel=4.14.0
+                 $(if $(CONFIG_PKG_RELRO_FULL),--enable-bind-now) \
+               --enable-kernel=5.4.0
 
 export libc_cv_ssp=no
 export libc_cv_ssp_strong=no