build: remove check to nonexistant CONFIG_ENABLE_LOCALE variable and move DISABLE_NLS...
[openwrt/staging/mkresin.git] / toolchain / gdb / Makefile
index 0aaa5e0dcb7508bf7e55503d7c09ae13db129068..10de1f883ff16f683c44f6b0d18b84027d383e61 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2009 OpenWrt.org
+#
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=6.8
+PKG_REV:=7.6-2013.05
+PKG_VERSION_MAJOR:=7.6
+PKG_VERSION:=linaro-$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=c9da266b884fb8fa54df786dfaadbc7a
-PKG_SOURCE_URL:=@GNU/gdb
+PKG_MD5SUM:=816290b91cff03912320089d353e8a12
+PKG_SOURCE_URL:=https://releases.linaro.org/13.05/components/toolchain/gdb-linaro/
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/toolchain-build.mk
 
@@ -25,7 +29,6 @@ define Host/Configure
                --host=$(GNU_HOST_NAME) \
                --target=$(REAL_GNU_TARGET_NAME) \
                --disable-werror \
-               $(DISABLE_NLS) \
                --without-uiout \
                --disable-tui --disable-gdbtk --without-x \
                --without-included-gettext \
@@ -33,10 +36,6 @@ define Host/Configure
        );
 endef
 
-define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR)
-endef
-
 define Host/Install
        mkdir -p $(TOOLCHAIN_DIR)/bin
        $(INSTALL_BIN) $(HOST_BUILD_DIR)/gdb/gdb $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)gdb