x86: Add kmod-dwmac-intel
[openwrt/staging/hauke.git] / target / linux / x86 / image / 64.mk
index 9c9decbf79adab5957bc027a38d5a4a86d0d8af3..f3d795ea22506ce6ed1357512049690cb9ca8a84 100644 (file)
@@ -1,7 +1,14 @@
 define Device/generic
-  DEVICE_TITLE := Generic x86/64
-  DEVICE_PACKAGES += kmod-amazon-ena kmod-bnx2 kmod-e1000e kmod-e1000 \
-       kmod-forcedeth kmod-igb kmod-ixgbe kmod-amd-xgbe kmod-r8169
+  DEVICE_VENDOR := Generic
+  DEVICE_MODEL := x86/64
+  DEVICE_PACKAGES += \
+       kmod-amazon-ena kmod-amd-xgbe kmod-bnx2 kmod-dwmac-intel kmod-e1000e kmod-e1000 \
+       kmod-forcedeth kmod-fs-vfat kmod-igb kmod-igc kmod-ixgbe kmod-r8169 \
+       kmod-tg3 kmod-mlxsw-core kmod-mlxsw-pci kmod-mlxsw-i2c \
+       kmod-mlxsw-spectrum kmod-mlxsw-minimal kmod-mlxfw \
+       kmod-leds-mlxcpld kmod-lib-objagg kmod-lib-parman \
+       kmod-hwmon-coretemp kmod-hwmon-drivetemp kmod-hwmon-jc42 \
+       kmod-i2c-i801 mlxsw_spectrum-firmware
   GRUB2_VARIANT := generic
 endef
 TARGET_DEVICES += generic