uml: add Kernel 6.1 support via testing
[openwrt/staging/jow.git] / target / linux / uml / Makefile
index 848af1f7cef36280ea824dacbedeae45e8904d1c..ba3c7eae9dc443a8df6694c18c4b3be52e17b745 100644 (file)
@@ -1,34 +1,26 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2006-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2006-2021 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/host.mk
 
 # UML only makes sense on linux
 ifeq ($(HOST_OS),Linux)
+  ifeq ($(HOST_ARCH),x86_64)
 
-ARCH:=$(shell uname -m | sed \
-       -e 's/i[3-9]86/i386/' \
-       -e 's/mipsel/mips/' \
-       -e 's/mipseb/mips/' \
-       -e 's/powerpc/ppc/' \
-       -e 's/sh[234]/sh/' \
-       -e 's/armeb/arm/' \
-)
+ARCH:=x86_64
 BOARD:=uml
 BOARDNAME:=User Mode Linux
-FEATURES:=ext4 audio
-LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
+FEATURES:=audio ext4 rootfs-part squashfs
 
-LINUX_VERSION:=2.6.32.27
+KERNEL_PATCHVER:=5.15
+KERNEL_TESTING_PATCHVER:=6.1
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += wpad-mini kmod-mac80211-hwsim
+DEFAULT_PACKAGES += wpad-basic-mbedtls kmod-mac80211-hwsim mkf2fs e2fsprogs
 
+  endif
 endif
 
 $(eval $(call BuildTarget))