uml: add Kernel 5.15 support via testing
[openwrt/openwrt.git] / target / linux / uml / Makefile
index 9342b1fa90674bcfb9bb3bb2b0b19446ee61f93d..90770cc0e4207b2c1eb22939d5a25e2a5a22ca98 100644 (file)
@@ -1,35 +1,26 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2006-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2006-2021 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/host.mk
 
 # UML only makes sense on linux
 ifeq ($(HOST_OS),Linux)
+  ifeq ($(HOST_ARCH),x86_64)
 
-ARCH:=$(shell uname -m | sed \
-       -e 's/i[3-9]86/i386/' \
-       -e 's/mipsel/mips/' \
-       -e 's/mipseb/mips/' \
-       -e 's/powerpc/ppc/' \
-       -e 's/sh[234]/sh/' \
-       -e 's/armeb/arm/' \
-)
+ARCH:=x86_64
 BOARD:=uml
 BOARDNAME:=User Mode Linux
-FEATURES:=ext4 audio
+FEATURES:=audio ext4 rootfs-part squashfs
 
-LINUX_VERSION:=2.6.37.6
+KERNEL_PATCHVER:=5.10
+KERNEL_TESTING_PATCHVER:=5.15
 
 include $(INCLUDE_DIR)/target.mk
 
-LINUX_TARGET_CONFIG:=$(CURDIR)/config/$(ARCH)
-
-DEFAULT_PACKAGES += wpad-mini kmod-mac80211-hwsim
+DEFAULT_PACKAGES += wpad-basic-wolfssl kmod-mac80211-hwsim mkf2fs e2fsprogs
 
+  endif
 endif
 
 $(eval $(call BuildTarget))