tegra: switch to Kernel 5.15 by default
[openwrt/staging/dedeckeh.git] / target / linux / tegra / Makefile
index 0b48fc16baa24b636f51950461f897b0ea378e92..43ca154e8a08d4c825f83a9df6b4f37ccb87eec4 100644 (file)
@@ -1,9 +1,7 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2017-2019 Tomasz Maciej Nowak <tomek_n@o2.pl>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2017-2019 Tomasz Maciej Nowak <tmn505@gmail.com>
+
 include $(TOPDIR)/rules.mk
 
 ARCH := arm
@@ -11,10 +9,10 @@ BOARD := tegra
 BOARDNAME := NVIDIA Tegra
 FEATURES := audio boot-part display ext4 fpu gpio pci pcie rootfs-part rtc squashfs usb
 CPU_TYPE := cortex-a9
-CPU_SUBTYPE := vfpv3
+CPU_SUBTYPE := vfpv3-d16
+SUBTARGETS := generic
 
-KERNEL_PATCHVER := 5.4
-KERNEL_TESTING_PATCHVER := 5.4
+KERNEL_PATCHVER := 5.15
 
 include $(INCLUDE_DIR)/target.mk