sunxi: fix build of rtc package when module not available
[openwrt/openwrt.git] / target / linux / sunxi / modules.mk
index 99b82a3b5f17348049458ced5823f7c90f784269..b8ea7d5cb66832d873024af7a5f66f2446681f06 100644 (file)
@@ -10,8 +10,8 @@ define KernelPackage/rtc-sunxi
     DEPENDS:=@TARGET_sunxi
     $(call AddDepends/rtc)
     KCONFIG:= \
-       CONFIG_RTC_CLASS=y \
-       CONFIG_RTC_DRV_SUNXI=m
+       CONFIG_RTC_DRV_SUNXI \
+       CONFIG_RTC_CLASS=y
     FILES:=$(LINUX_DIR)/drivers/rtc/rtc-sunxi.ko
     AUTOLOAD:=$(call AutoLoad,50,rtc-sunxi)
 endef