treewide: replace wpad-basic-wolfssl default
[openwrt/staging/jow.git] / target / linux / sunxi / image / cortexa7.mk
index 083010ad8c146046ee0cf324ccb044b1713e4e25..5b9f27cef80393b3ec9b8051de56181f56ddb970 100644 (file)
@@ -1,10 +1,7 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2013-2019 OpenWrt.org
 # Copyright (C) 2016 Yousong Zhou
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
 
 define Device/cubietech_cubieboard2
   DEVICE_VENDOR := Cubietech
@@ -25,8 +22,8 @@ TARGET_DEVICES += cubietech_cubietruck
 define Device/friendlyarm_nanopi-m1-plus
   DEVICE_VENDOR := FriendlyARM
   DEVICE_MODEL := NanoPi M1 Plus
-  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-leds-gpio kmod-ledtrig-heartbeat \
-       kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic-wolfssl
+  DEVICE_PACKAGES:=kmod-leds-gpio kmod-brcmfmac \
+       cypress-firmware-43430-sdio wpad-basic-mbedtls
   SOC := sun8i-h3
 endef
 TARGET_DEVICES += friendlyarm_nanopi-m1-plus
@@ -41,16 +38,37 @@ TARGET_DEVICES += friendlyarm_nanopi-neo
 define Device/friendlyarm_nanopi-neo-air
   DEVICE_VENDOR := FriendlyARM
   DEVICE_MODEL := NanoPi NEO Air
-  DEVICE_PACKAGES := kmod-rtc-sunxi kmod-leds-gpio kmod-ledtrig-heartbeat \
-       kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic-wolfssl
+  DEVICE_PACKAGES := kmod-leds-gpio kmod-brcmfmac \
+       brcmfmac-firmware-43430a0-sdio wpad-basic-mbedtls
   SOC := sun8i-h3
 endef
 TARGET_DEVICES += friendlyarm_nanopi-neo-air
 
+define Device/friendlyarm_nanopi-r1
+  DEVICE_VENDOR := FriendlyARM
+  DEVICE_MODEL := NanoPi R1
+  DEVICE_PACKAGES := kmod-usb-net-rtl8152 kmod-leds-gpio \
+       kmod-brcmfmac cypress-firmware-43430-sdio wpad-basic-mbedtls
+  SOC := sun8i-h3
+endef
+TARGET_DEVICES += friendlyarm_nanopi-r1
+
+define Device/friendlyarm_zeropi
+  DEVICE_VENDOR := FriendlyARM
+  DEVICE_MODEL := ZeroPi
+  DEVICE_PACKAGES := kmod-rtc-sunxi
+  SOC := sun8i-h3
+endef
+TARGET_DEVICES += friendlyarm_zeropi
+
 define Device/lamobo_lamobo-r1
   DEVICE_VENDOR := Lamobo
   DEVICE_MODEL := Lamobo R1
-  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtl8192cu swconfig wpad-basic-wolfssl
+  DEVICE_ALT0_VENDOR := Bananapi
+  DEVICE_ALT0_MODEL := BPi-R1
+  DEVICE_PACKAGES := kmod-ata-sunxi kmod-rtl8192cu wpad-basic-mbedtls
+  DEVICE_COMPAT_VERSION := 1.1
+  DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA
   SOC := sun7i-a20
 endef
 TARGET_DEVICES += lamobo_lamobo-r1
@@ -63,13 +81,25 @@ define Device/lemaker_bananapi
 endef
 TARGET_DEVICES += lemaker_bananapi
 
-define Device/lemaker_bananapi-m2-ultra
-  DEVICE_VENDOR := LeMaker
+define Device/sinovoip_bananapi-m2-berry
+  DEVICE_VENDOR := Sinovoip
+  DEVICE_MODEL := Banana Pi M2 Berry
+  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-brcmfmac \
+       cypress-firmware-43430-sdio wpad-basic-mbedtls
+  SUPPORTED_DEVICES:=lemaker,bananapi-m2-berry
+  SOC := sun8i-v40
+endef
+TARGET_DEVICES += sinovoip_bananapi-m2-berry
+
+define Device/sinovoip_bananapi-m2-ultra
+  DEVICE_VENDOR := Sinovoip
   DEVICE_MODEL := Banana Pi M2 Ultra
-  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-sunxi
+  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-brcmfmac \
+       brcmfmac-firmware-43430a0-sdio wpad-basic-mbedtls
+  SUPPORTED_DEVICES:=lemaker,bananapi-m2-ultra
   SOC := sun8i-r40
 endef
-TARGET_DEVICES += lemaker_bananapi-m2-ultra
+TARGET_DEVICES += sinovoip_bananapi-m2-ultra
 
 define Device/lemaker_bananapro
   DEVICE_VENDOR := LeMaker
@@ -88,10 +118,18 @@ define Device/linksprite_pcduino3
 endef
 TARGET_DEVICES += linksprite_pcduino3
 
+define Device/linksprite_pcduino3-nano
+  DEVICE_VENDOR := LinkSprite
+  DEVICE_MODEL := pcDuino3 Nano
+  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-sunxi
+  SOC := sun7i-a20
+endef
+TARGET_DEVICES += linksprite_pcduino3-nano
+
 define Device/mele_m9
   DEVICE_VENDOR := Mele
   DEVICE_MODEL := M9
-  DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-rtl8192cu
+  DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtl8192cu
   SOC := sun6i-a31
 endef
 TARGET_DEVICES += mele_m9
@@ -132,8 +170,8 @@ TARGET_DEVICES += olimex_a20-olinuxino-micro
 define Device/sinovoip_bananapi-m2-plus
   DEVICE_VENDOR := Sinovoip
   DEVICE_MODEL := Banana Pi M2+
-  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-leds-gpio kmod-ledtrig-heartbeat \
-       kmod-brcmfmac brcmfmac-firmware-43430a0-sdio wpad-basic-wolfssl
+  DEVICE_PACKAGES:=kmod-leds-gpio kmod-brcmfmac \
+       brcmfmac-firmware-43430a0-sdio wpad-basic-mbedtls
   SOC := sun8i-h3
 endef
 TARGET_DEVICES += sinovoip_bananapi-m2-plus
@@ -149,7 +187,7 @@ TARGET_DEVICES += xunlong_orangepi-one
 define Device/xunlong_orangepi-pc
   DEVICE_VENDOR := Xunlong
   DEVICE_MODEL := Orange Pi PC
-  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
+  DEVICE_PACKAGES:=kmod-gpio-button-hotplug
   SOC := sun8i-h3
 endef
 TARGET_DEVICES += xunlong_orangepi-pc
@@ -157,7 +195,7 @@ TARGET_DEVICES += xunlong_orangepi-pc
 define Device/xunlong_orangepi-pc-plus
   DEVICE_VENDOR := Xunlong
   DEVICE_MODEL := Orange Pi PC Plus
-  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
+  DEVICE_PACKAGES:=kmod-gpio-button-hotplug
   SOC := sun8i-h3
 endef
 TARGET_DEVICES += xunlong_orangepi-pc-plus
@@ -173,7 +211,7 @@ TARGET_DEVICES += xunlong_orangepi-plus
 define Device/xunlong_orangepi-r1
   DEVICE_VENDOR := Xunlong
   DEVICE_MODEL := Orange Pi R1
-  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-usb-net-rtl8152
+  DEVICE_PACKAGES:=kmod-usb-net-rtl8152
   SOC := sun8i-h2-plus
 endef
 TARGET_DEVICES += xunlong_orangepi-r1