sunxi: Orange Pi R1 SPI: add spi flash board
[openwrt/staging/hauke.git] / target / linux / sunxi / image / cortex-a7.mk
index d219a1d097a3d108eb64e555f2782b061886eb0f..6cc87d49c1c26eb2db0bccedf09948dc27e7f1be 100644 (file)
@@ -8,6 +8,15 @@
 
 ifeq ($(SUBTARGET),cortexa7)
 
+define Build/append-uboot
+       dd if=$(STAGING_DIR_IMAGE)/$(DEVICE_NAME)-u-boot-with-spl.bin >> $@
+endef
+
+define Build/add-dtb
+       dd if=$(DTS_DIR)/$(SUNXI_DTS).dtb >> $@
+endef
+
+
 define Device/sun7i-a20-olinuxino-lime
   DEVICE_TITLE:=Olimex A20-OLinuXino-LIME
   DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi
@@ -118,6 +127,31 @@ endef
 TARGET_DEVICES += sun8i-h2-plus-orangepi-r1
 
 
+define Device/sun8i-h2-plus-orangepi-r1-spi
+  FILESYSTEMS := squashfs
+  IMAGES := spi-factory.img
+  IMAGE/spi-factory.img := append-uboot | check-size 512k | pad-to 576k | add-dtb | pad-to 640k | append-kernel | append-rootfs | pad-rootfs | append-metadata
+  DEVICE_TITLE:=Xunlong Orange Pi R1 boot from SPI
+  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-usb-net kmod-usb-net-rtl8152
+  SUPPORTED_DEVICES:=xunlong,orangepi-r1-spi
+  SUNXI_DTS:=sun8i-h2-plus-orangepi-r1
+endef
+
+TARGET_DEVICES += sun8i-h2-plus-orangepi-r1-spi
+
+
+define Device/sun8i-h3-nanopi-m1-plus
+  DEVICE_TITLE:=FriendlyArm NanoPi M1 Plus
+  DEVICE_PACKAGES:=kmod-rtc-sunxi \
+       kmod-leds-gpio kmod-ledtrig-heartbeat \
+       kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-mini
+  SUPPORTED_DEVICES:=friendlyarm,nanopi-m1-plus
+  SUNXI_DTS:=sun8i-h3-nanopi-m1-plus
+endef
+
+TARGET_DEVICES += sun8i-h3-nanopi-m1-plus
+
+
 define Device/sun8i-h3-nanopi-neo
   DEVICE_TITLE:=FriendlyARM NanoPi NEO
   SUPPORTED_DEVICES:=friendlyarm,nanopi-neo
@@ -127,6 +161,16 @@ endef
 TARGET_DEVICES += sun8i-h3-nanopi-neo
 
 
+define Device/sun8i-h3-orangepi-pc
+  DEVICE_TITLE:=Xunlong Orange Pi PC
+  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
+  SUPPORTED_DEVICES:=xunlong,orangepi-pc
+  SUNXI_DTS:=sun8i-h3-orangepi-pc
+endef
+
+TARGET_DEVICES += sun8i-h3-orangepi-pc
+
+
 define Device/sun8i-h3-orangepi-plus
   DEVICE_TITLE:=Xunlong Orange Pi Plus
   DEVICE_PACKAGES:=kmod-rtc-sunxi