ramips: add Poray IP2202 support
[openwrt/openwrt.git] / target / linux / ramips / rt305x / profiles / poray.mk
index 86b9a8b8fce5cb6f11b8885a297ae4b97e6f13f4..ed017b7d8432810a2d5099daa9304680a58988cd 100644 (file)
@@ -5,6 +5,18 @@
 # See /LICENSE for more information.
 #
 
+define Profile/IP2202
+       NAME:=Poray IP2202
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-usb-rt305x-dwc_otg \
+       kmod-ledtrig-netdev kmod-ledtrig-timer restorefactory
+endef
+
+define Profile/IP2202/Description
+       Package set for Poray IP2202 board
+endef
+
+$(eval $(call Profile,IP2202))
+
 define Profile/M3
        NAME:=Poray M3
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-netdev kmod-ledtrig-timer
@@ -35,3 +47,13 @@ define Profile/X5/Description
 endef
 
 $(eval $(call Profile,X5))
+
+define Profile/X8
+       NAME:=Poray X8
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-netdev kmod-ledtrig-timer
+endef
+define Profile/X8/Description
+       Package set for Poray X8 board
+endef
+
+$(eval $(call Profile,X8))