kernel: update 3.10 to 3.10.26
[openwrt/staging/florian.git] / target / linux / ramips / patches-3.10 / 0301-asoc-add-mt7620-support.patch
index 9957fb0b8265612197f6601f27f87633bffc7cfe..c85f4177a082062bc2f528c92ee9db0937a381c4 100644 (file)
@@ -19,11 +19,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  create mode 100644 sound/soc/ralink/mt7620-pcm.c
  create mode 100644 sound/soc/ralink/mt7620-wm8960.c
 
-Index: linux-3.10.18/sound/soc/Kconfig
-===================================================================
---- linux-3.10.18.orig/sound/soc/Kconfig       2013-11-04 13:31:29.000000000 +0100
-+++ linux-3.10.18/sound/soc/Kconfig    2013-12-04 17:52:32.884756569 +0100
-@@ -48,6 +48,7 @@
+--- a/sound/soc/Kconfig
++++ b/sound/soc/Kconfig
+@@ -48,6 +48,7 @@ source "sound/soc/kirkwood/Kconfig"
  source "sound/soc/mid-x86/Kconfig"
  source "sound/soc/mxs/Kconfig"
  source "sound/soc/pxa/Kconfig"
@@ -31,11 +29,9 @@ Index: linux-3.10.18/sound/soc/Kconfig
  source "sound/soc/samsung/Kconfig"
  source "sound/soc/s6000/Kconfig"
  source "sound/soc/sh/Kconfig"
-Index: linux-3.10.18/sound/soc/Makefile
-===================================================================
---- linux-3.10.18.orig/sound/soc/Makefile      2013-11-04 13:31:29.000000000 +0100
-+++ linux-3.10.18/sound/soc/Makefile   2013-12-04 17:52:32.884756569 +0100
-@@ -26,6 +26,7 @@
+--- a/sound/soc/Makefile
++++ b/sound/soc/Makefile
+@@ -26,6 +26,7 @@ obj-$(CONFIG_SND_SOC)        += nuc900/
  obj-$(CONFIG_SND_SOC) += omap/
  obj-$(CONFIG_SND_SOC) += kirkwood/
  obj-$(CONFIG_SND_SOC) += pxa/
@@ -43,10 +39,8 @@ Index: linux-3.10.18/sound/soc/Makefile
  obj-$(CONFIG_SND_SOC) += samsung/
  obj-$(CONFIG_SND_SOC) += s6000/
  obj-$(CONFIG_SND_SOC) += sh/
-Index: linux-3.10.18/sound/soc/ralink/Kconfig
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.10.18/sound/soc/ralink/Kconfig     2013-12-04 17:52:32.884756569 +0100
+--- /dev/null
++++ b/sound/soc/ralink/Kconfig
 @@ -0,0 +1,15 @@
 +config SND_MT7620_SOC_I2S
 +      depends on SOC_MT7620 && SND_SOC
@@ -63,10 +57,8 @@ Index: linux-3.10.18/sound/soc/ralink/Kconfig
 +      help
 +        Say Y if you want to add support for ASoC audio on the Qi LB60 board
 +        a.k.a Qi Ben NanoNote.
-Index: linux-3.10.18/sound/soc/ralink/Makefile
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.10.18/sound/soc/ralink/Makefile    2013-12-04 17:52:32.884756569 +0100
+--- /dev/null
++++ b/sound/soc/ralink/Makefile
 @@ -0,0 +1,11 @@
 +#
 +# Jz4740 Platform Support
@@ -79,10 +71,8 @@ Index: linux-3.10.18/sound/soc/ralink/Makefile
 +snd-soc-mt7620-wm8960-objs := mt7620-wm8960.o
 +
 +obj-$(CONFIG_SND_MT7620_SOC_WM8960) += snd-soc-mt7620-wm8960.o
-Index: linux-3.10.18/sound/soc/ralink/mt7620-i2s.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.10.18/sound/soc/ralink/mt7620-i2s.c        2013-12-05 21:18:46.913130624 +0100
+--- /dev/null
++++ b/sound/soc/ralink/mt7620-i2s.c
 @@ -0,0 +1,466 @@
 +/*
 + *  Copyright (C) 2010, Lars-Peter Clausen <lars@metafoo.de>
@@ -550,10 +540,8 @@ Index: linux-3.10.18/sound/soc/ralink/mt7620-i2s.c
 +MODULE_DESCRIPTION("Ingenic JZ4740 SoC I2S driver");
 +MODULE_LICENSE("GPL");
 +MODULE_ALIAS("platform:mt7620-i2s");
-Index: linux-3.10.18/sound/soc/ralink/mt7620-wm8960.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.10.18/sound/soc/ralink/mt7620-wm8960.c     2013-12-04 17:52:32.884756569 +0100
+--- /dev/null
++++ b/sound/soc/ralink/mt7620-wm8960.c
 @@ -0,0 +1,125 @@
 +/*
 + * Copyright (C) 2009, Lars-Peter Clausen <lars@metafoo.de>
@@ -680,10 +668,8 @@ Index: linux-3.10.18/sound/soc/ralink/mt7620-wm8960.c
 +MODULE_DESCRIPTION("ALSA SoC QI LB60 Audio support");
 +MODULE_LICENSE("GPL v2");
 +MODULE_ALIAS("platform:qi-lb60-audio");
-Index: linux-3.10.18/arch/mips/ralink/of.c
-===================================================================
---- linux-3.10.18.orig/arch/mips/ralink/of.c   2013-12-04 17:52:32.736756565 +0100
-+++ linux-3.10.18/arch/mips/ralink/of.c        2013-12-04 17:52:32.884756569 +0100
+--- a/arch/mips/ralink/of.c
++++ b/arch/mips/ralink/of.c
 @@ -15,6 +15,7 @@
  #include <linux/of_fdt.h>
  #include <linux/kernel.h>
@@ -700,10 +686,8 @@ Index: linux-3.10.18/arch/mips/ralink/of.c
  __iomem void *rt_memc_membase;
  
  extern struct boot_param_header __dtb_start;
-Index: linux-3.10.18/sound/soc/soc-io.c
-===================================================================
---- linux-3.10.18.orig/sound/soc/soc-io.c      2013-11-04 13:31:29.000000000 +0100
-+++ linux-3.10.18/sound/soc/soc-io.c   2013-12-04 17:52:32.888756569 +0100
+--- a/sound/soc/soc-io.c
++++ b/sound/soc/soc-io.c
 @@ -19,7 +19,6 @@
  
  #include <trace/events/asoc.h>
@@ -712,7 +696,7 @@ Index: linux-3.10.18/sound/soc/soc-io.c
  static int hw_write(struct snd_soc_codec *codec, unsigned int reg,
                    unsigned int value)
  {
-@@ -161,12 +160,3 @@
+@@ -161,12 +160,3 @@ int snd_soc_codec_set_cache_io(struct sn
        return PTR_RET(codec->control_data);
  }
  EXPORT_SYMBOL_GPL(snd_soc_codec_set_cache_io);