ramips: add support for Belkin F9K1109v1
[openwrt/openwrt.git] / target / linux / ramips / image / rt3883.mk
index abee533d01019410de6bd662b5b75e9413fd6357..41b2c3dd5fb2c2a2e54babf1b22dd9eb0af4b7cf 100644 (file)
@@ -41,6 +41,18 @@ endef
 TARGET_DEVICES += dir-645
 
 
+define Device/belkin_f9k1109v1
+  DTS := F9K1109V1
+  BLOCKSIZE := 64k
+  DEVICE_TITLE := Belkin F9K1109 Version 1.0
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+  IMAGE_SIZE := 7224k
+  KERNEL := kernel-bin | patch-dtb | lzma -d16 | uImage lzma
+  # Stock firmware checks for this uImage image name during upload.
+  UIMAGE_NAME := N750F9K1103VB
+endef
+TARGET_DEVICES += belkin_f9k1109v1
+
 define Device/hpm
   DTS := HPM
   BLOCKSIZE := 64k