treewide: omit IMAGE_SIZE argument from check-size
[openwrt/staging/thess.git] / target / linux / ramips / image / common-tp-link.mk
index 587ef89fc103022df135769cd396ac892e6a4a7a..07ad1ea25025280b7f2e196042594b6aba1ed40f 100644 (file)
@@ -12,7 +12,7 @@ define Device/tplink-v1
   IMAGES += factory.bin
   IMAGE/factory.bin := tplink-v1-image factory -e -O
   IMAGE/sysupgrade.bin := tplink-v1-image sysupgrade -e -O | append-metadata | \
-       check-size $$$$(IMAGE_SIZE)
+       check-size
 endef
 
 define Device/tplink-v2
@@ -27,7 +27,7 @@ define Device/tplink-v2
   IMAGES += factory.bin
   IMAGE/factory.bin := tplink-v2-image -e
   IMAGE/sysupgrade.bin := tplink-v2-image -s -e | append-metadata | \
-       check-size $$$$(IMAGE_SIZE)
+       check-size
 endef
 
 define Device/tplink-safeloader
@@ -39,6 +39,6 @@ define Device/tplink-safeloader
   KERNEL := $(KERNEL_DTB) | tplink-v1-header -e -O
   IMAGES += factory.bin
   IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | \
-       append-metadata | check-size $$$$(IMAGE_SIZE)
+       append-metadata | check-size
   IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
 endef