ramips: add support for Loewe WMDR-143N
[openwrt/openwrt.git] / target / linux / ramips / Makefile
index eafd2742e6aa086f5017406ce8416530d425caa7..ad6cbca0eae272c73aa4aa98c8fca1315ad4ecd0 100644 (file)
@@ -8,19 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT3xxx
+BOARDNAME:=MediaTek Ralink MIPS
 SUBTARGETS:=rt305x mt7620 mt7621 mt7628 mt7688 rt3883 rt288x
 FEATURES:=squashfs gpio
-MAINTAINER:=John Crispin <blogic@openwrt.org>
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-KERNEL_PATCHVER:=3.18
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug wpad-mini swconfig
+KERNEL_PATCHVER:=4.9
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig
+
 $(eval $(call BuildTarget))