build: unify target independent optimization options
[openwrt/staging/mkresin.git] / target / linux / ppc40x / Makefile
index b081849db803dc646fa6b425f6e6518e4ec6dd4e..3ae5ca9d1751f374d78f09343e548c1995af3a6b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,16 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=powerpc
 BOARD:=ppc40x
-BOARDNAME:=AMCC Kilauea
+BOARDNAME:=AMCC/IBM PPC40x
 FEATURES:=squashfs
+CFLAGS:=-Os -pipe -mcpu=405
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.24.2
-LINUX_KARCH:=powerpc
+LINUX_VERSION:=3.8.13
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build firmware images for the AMCC Kilauea evaluation board
+       Build firmware images for AMCC/IBM PPC40x based boards.
 endef
 
+KERNELNAME:="uImage cuImage.magicbox cuImage.openrb"
+
 $(eval $(call BuildTarget))