omap: rework image generation and profiles
[openwrt/openwrt.git] / target / linux / omap / Makefile
index bc861f1117009bc8372634f805e89cf98474ba28..34dc9a4b5e74126b1fd0757472202fb694cb5dd5 100644 (file)
@@ -4,13 +4,14 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=omap
 BOARDNAME:=TI OMAP3/4/AM33xx
 FEATURES:=usb usbgadget ext4 targz fpu audio display nand ubifs
-CPU_TYPE:=cortex-a9
+CPU_TYPE:=cortex-a8
 CPU_SUBTYPE:=vfpv3
 
 KERNEL_PATCHVER:=4.4
@@ -19,12 +20,10 @@ MAINTAINER:=Alexander Couzens <lynxis@fe80.eu>
 
 KERNELNAME:=zImage dtbs
 
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
-
 define Target/Description
        TI OMAP boards
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))