octeon: switch to kernel 4.14
[openwrt/staging/lynxis.git] / target / linux / octeon / Makefile
index 5cddd2de854469c1d52c18e944abe54869097ad4..bbf1296c21e9134f1582f685ccdad5014c9f08c0 100644 (file)
@@ -9,17 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs ext4 initramfs pci usb
+FEATURES:=squashfs ramdisk pci usb
 CPU_TYPE:=octeon
 MAINTAINER:=John Crispin <john@phrozen.org>
 
-KERNEL_PATCHVER:=4.4
-
-include $(INCLUDE_DIR)/target.mk
-
+KERNEL_PATCHVER:=4.14
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))