kernel: update kernel 4.4 to version 4.4.3
[openwrt/staging/yousong.git] / target / linux / mxs / patches-4.4 / 102-mxs-add-regulator-driver.patch
index 4690b3c6d450d4dab176d29bf700baa7e6328be9..cb658c9aeeb47e5fc5709109c0253c27032e008c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/regulator/Kconfig
 +++ b/drivers/regulator/Kconfig
-@@ -450,6 +450,14 @@ config REGULATOR_MT6397
+@@ -461,6 +461,14 @@ config REGULATOR_MT6397
          This driver supports the control of different power rails of device
          through regulator interface.
  
        depends on MFD_PALMAS
 --- a/drivers/regulator/Makefile
 +++ b/drivers/regulator/Makefile
-@@ -60,6 +60,7 @@ obj-$(CONFIG_REGULATOR_MC13783) += mc137
- obj-$(CONFIG_REGULATOR_MC13892) += mc13892-regulator.o
+@@ -61,6 +61,7 @@ obj-$(CONFIG_REGULATOR_MC13892) += mc138
  obj-$(CONFIG_REGULATOR_MC13XXX_CORE) +=  mc13xxx-regulator-core.o
+ obj-$(CONFIG_REGULATOR_MT6311) += mt6311-regulator.o
  obj-$(CONFIG_REGULATOR_MT6397)        += mt6397-regulator.o
 +obj-$(CONFIG_REGULATOR_MXS) += mxs-regulator.o
  obj-$(CONFIG_REGULATOR_QCOM_RPM) += qcom_rpm-regulator.o
- obj-$(CONFIG_REGULATOR_PALMAS) += palmas-regulator.o
- obj-$(CONFIG_REGULATOR_PFUZE100) += pfuze100-regulator.o
+ obj-$(CONFIG_REGULATOR_QCOM_SMD_RPM) += qcom_smd-regulator.o
+ obj-$(CONFIG_REGULATOR_QCOM_SPMI) += qcom_spmi-regulator.o
 --- /dev/null
 +++ b/drivers/regulator/mxs-regulator.c
 @@ -0,0 +1,540 @@