mvebu: switch default kernel to 5.15
[openwrt/openwrt.git] / target / linux / mvebu / Makefile
index 177107c5c7404616545616395904ab0c0d3b2ff3..2971f3fcaf504a8297b6c1e78d6a543f92cc0319 100644 (file)
@@ -1,25 +1,18 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2012-2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2012-2015 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
 
-ARCH:=arm
 BOARD:=mvebu
-BOARDNAME:=Marvell Armada XP/370
-FEATURES:=targz usb pci pcie gpio nand squashfs
-CPU_TYPE:=cortex-a9
-CPU_SUBTYPE:=vfpv3
-MAINTAINER:=Luka Perkov <luka@openwrt.org>
+BOARDNAME:=Marvell EBU Armada
+FEATURES:=fpu usb pci pcie gpio nand squashfs ramdisk boot-part rootfs-part legacy-sdcard targz
+SUBTARGETS:=cortexa9 cortexa53 cortexa72
 
-LINUX_VERSION:=3.14.9
+KERNEL_PATCHVER:=5.15
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage dtbs"
-
-DEFAULT_PACKAGES += uboot-envtools
+DEFAULT_PACKAGES += uboot-envtools kmod-gpio-button-hotplug
 
 $(eval $(call BuildTarget))