mpc85xx: switch to 6.1 kernel
[openwrt/staging/stintel.git] / target / linux / mpc85xx / Makefile
index efd48d7d41cc3d93fd60dde2cf6c7bd0e2996d46..bcbd430a656594bfaf1a674eced4dc6b9c89d59a 100644 (file)
@@ -1,34 +1,25 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CPU_TYPE:=8540
-FEATURES:=squashfs
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS=generic p1020
+CPU_TYPE:=8548
+FEATURES:=squashfs ramdisk nand
+SUBTARGETS:=p1010 p1020 p2020
 
-KERNEL_PATCHVER:=4.4
+KERNEL_PATCHVER:=6.1
 
-include $(INCLUDE_DIR)/target.mk
+KERNELNAME:=zImage
 
-KERNEL_IMAGES := zImage
-ifeq ($(SUBTARGET),generic)
-KERNEL_IMAGES += cuImage.tl-wdr4900-v1
-endif
+include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio swconfig kmod-ath9k wpad-mini
-
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+       kmod-leds-gpio swconfig kmod-ath9k wpad-basic-mbedtls kmod-usb2 \
+       uboot-envtools
 
 $(eval $(call BuildTarget))