mpc85xx: switch to 6.1 kernel
[openwrt/staging/stintel.git] / target / linux / mpc85xx / Makefile
index 370ef81f15c1562e74f2f8a2ae15fd5fc330434d..bcbd430a656594bfaf1a674eced4dc6b9c89d59a 100644 (file)
@@ -1,20 +1,17 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CPU_TYPE:=8540
-FEATURES:=squashfs ramdisk
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS:=generic p1020 p2020
+CPU_TYPE:=8548
+FEATURES:=squashfs ramdisk nand
+SUBTARGETS:=p1010 p1020 p2020
 
-KERNEL_PATCHVER:=4.14
+KERNEL_PATCHVER:=6.1
 
 KERNELNAME:=zImage
 
@@ -22,6 +19,7 @@ include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio swconfig kmod-ath9k wpad-basic
+       kmod-leds-gpio swconfig kmod-ath9k wpad-basic-mbedtls kmod-usb2 \
+       uboot-envtools
 
 $(eval $(call BuildTarget))