build: unify target independent optimization options
[openwrt/staging/jow.git] / target / linux / mpc83xx / Makefile
index c0e1d89f887019464185fafaca74b46201aa674e..1bb0d34bbcba455c15a4c7692ddf3e9172cefbb5 100644 (file)
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc83xx
 BOARDNAME:=Freescale MPC83xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
+CFLAGS:=-Os -pipe -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.2
+LINUX_VERSION:=3.8.13
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -23,4 +23,6 @@ define Target/Description
        Build firmware images for Freescale MPC83xx based boards (eg. RouterBoard 600).
 endef
 
+KERNELNAME:="uImage"
+
 $(eval $(call BuildTarget))