mediatek: update patches
[openwrt/openwrt.git] / target / linux / mediatek / patches-4.4 / 0023-ARM-dts-mediatek-add-MT7623-basic-support.patch
index 85ff55128f7d4dcc20325dd2a7fb01a824db581e..b25c91bee8eac9e62028b6f8b63e81be1ee13aec 100644 (file)
@@ -1,7 +1,7 @@
-From cfe366d7a20f88c7fc92faaf8b25c24e730bd40b Mon Sep 17 00:00:00 2001
+From a4df3e7e4e906a4e9dac1f8c43f6192f22ef6242 Mon Sep 17 00:00:00 2001
 From: John Crispin <blogic@openwrt.org>
 Date: Tue, 5 Jan 2016 12:16:17 +0100
-Subject: [PATCH 23/53] ARM: dts: mediatek: add MT7623 basic support
+Subject: [PATCH 23/78] ARM: dts: mediatek: add MT7623 basic support
 
 This adds basic chip support for Mediatek MT7623.
 
@@ -9,10 +9,10 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 ---
  arch/arm/boot/dts/Makefile        |    1 +
  arch/arm/boot/dts/mt7623-evb.dts  |  459 +++++++++++++++++++++++++++++++++
- arch/arm/boot/dts/mt7623.dtsi     |  507 +++++++++++++++++++++++++++++++++++++
+ arch/arm/boot/dts/mt7623.dtsi     |  510 +++++++++++++++++++++++++++++++++++++
  arch/arm/mach-mediatek/Kconfig    |    4 +
  arch/arm/mach-mediatek/mediatek.c |    1 +
- 5 files changed, 972 insertions(+)
+ 5 files changed, 975 insertions(+)
  create mode 100644 arch/arm/boot/dts/mt7623-evb.dts
  create mode 100644 arch/arm/boot/dts/mt7623.dtsi
 
@@ -495,10 +495,10 @@ index 0000000..5e9381d
 +};
 diff --git a/arch/arm/boot/dts/mt7623.dtsi b/arch/arm/boot/dts/mt7623.dtsi
 new file mode 100644
-index 0000000..1ba7790
+index 0000000..c53c10d
 --- /dev/null
 +++ b/arch/arm/boot/dts/mt7623.dtsi
-@@ -0,0 +1,507 @@
+@@ -0,0 +1,510 @@
 +/*
 + * Copyright (c) 2016 MediaTek Inc.
 + * Author: John Crispin <blogic@openwrt.org>
@@ -530,6 +530,7 @@ index 0000000..1ba7790
 +      cpus {
 +              #address-cells = <1>;
 +              #size-cells = <0>;
++              enable-method = "mediatek,mt6589-smp";
 +
 +              cpu@0 {
 +                      device_type = "cpu";
@@ -954,7 +955,9 @@ index 0000000..1ba7790
 +      
 +              clocks = <&topckgen CLK_TOP_ETHIF_SEL>;
 +              clock-names = "ethif";
-+              interrupts = <GIC_SPI 200 IRQ_TYPE_LEVEL_LOW>;
++              interrupts = <GIC_SPI 200 IRQ_TYPE_LEVEL_LOW
++                            GIC_SPI 199 IRQ_TYPE_LEVEL_LOW
++                            GIC_SPI 198 IRQ_TYPE_LEVEL_LOW>;
 +              power-domains = <&scpsys MT2701_POWER_DOMAIN_ETH>;
 +
 +              mediatek,ethsys = <&ethsys>;