tools/padjffs2: use Host/Prepare/Default instead of raw commands
[openwrt/staging/stintel.git] / target / linux / mediatek / Makefile
index 6b30f3b19d7843b23d92d324b7ff225244739537..f667081253d3fd5502371765ce297a57dc09bc52 100644 (file)
@@ -5,17 +5,13 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=mediatek
 BOARDNAME:=MediaTek Ralink ARM
-SUBTARGETS:=32
-FEATURES:=squashfs nand ramdisk fpu
-MAINTAINER:=John Crispin <john@phrozen.org>
+SUBTARGETS:=mt7622 mt7623 mt7629 filogic
+FEATURES:=dt-overlay emmc fpu gpio nand pci pcie rootfs-part separate_ramdisk squashfs usb
 
-KERNEL_PATCHVER:=4.14
-
-KERNELNAME:=Image dtbs zImage
+KERNEL_PATCHVER:=6.6
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
-       kmod-mt76 kmod-leds-gpio kmod-gpio-button-hotplug \
-       wpad-mini
+       kmod-leds-gpio kmod-gpio-button-hotplug
 
 $(eval $(call BuildTarget))