malta: Use kernel 6.1 by default
[openwrt/openwrt.git] / target / linux / malta / Makefile
index 21f8345d0169fa0e618824ae9ff9e9da687f456a..f98aedf577f3f20586327599ac05bc23a1ab4a2e 100644 (file)
@@ -1,23 +1,19 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2010-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 BOARD:=malta
 BOARDNAME:=MIPS Malta CoreLV board (qemu)
 SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
-MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-
-LINUX_VERSION:=3.10.34
+FEATURES:=cpiogz ext4 ramdisk squashfs targz
 
-DEVICE_TYPE:=developerboard
+KERNEL_PATCHVER:=6.1
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += wpad-mini kmod-mac80211-hwsim kmod-pcnet32
+DEFAULT_PACKAGES += wpad-basic-mbedtls kmod-mac80211-hwsim kmod-pcnet32 mkf2fs e2fsprogs
 
 $(eval $(call BuildTarget))