layerscape: support sysupgrade for SD card ext4 rootfs
[openwrt/staging/mkresin.git] / target / linux / layerscape / Makefile
index e5bb1932d8d9e1581cf6da69f9ff634a82a16d42..c5b27ad0c7c33adafe4dda551888f0186dcfd7d2 100644 (file)
@@ -8,10 +8,9 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=layerscape
 BOARDNAME:=NXP Layerscape
-KERNEL_PATCHVER:=4.9
-FEATURES:=squashfs nand usb pcie gpio fpu ubifs
-SUBTARGETS:=armv8_64b armv8_32b
-MAINTAINER:=Yangbo Lu <yangbo.lu@nxp.com>
+KERNEL_PATCHVER:=5.4
+FEATURES:=squashfs nand usb pcie gpio fpu ubifs ext4
+SUBTARGETS:=armv8_64b armv7
 
 define Target/Description
        Build firmware images for NXP Layerscape based boards.
@@ -19,6 +18,7 @@ endef
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-usb3 kmod-usb-dwc3 kmod-usb-storage
+DEFAULT_PACKAGES += kmod-usb3 kmod-usb-dwc3 kmod-usb-storage \
+  partx-utils
 
 $(eval $(call BuildTarget))