layerscape: support sysupgrade for SD card ext4 rootfs
[openwrt/staging/mkresin.git] / target / linux / layerscape / Makefile
index 9c92bb48962879a5415ad0e40c073e87d8150d3c..c5b27ad0c7c33adafe4dda551888f0186dcfd7d2 100644 (file)
@@ -8,11 +8,9 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=layerscape
 BOARDNAME:=NXP Layerscape
-DEVICE_TYPE:=developerboard
-KERNEL_PATCHVER:=4.4
-FEATURES:=squashfs nand usb pcie gpio
-SUBTARGETS:=armv8_64b armv8_32b
-MAINTAINER:=Yangbo Lu <yangbo.lu@nxp.com>
+KERNEL_PATCHVER:=5.4
+FEATURES:=squashfs nand usb pcie gpio fpu ubifs ext4
+SUBTARGETS:=armv8_64b armv7
 
 define Target/Description
        Build firmware images for NXP Layerscape based boards.
@@ -20,6 +18,7 @@ endef
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-usb3 kmod-usb-dwc3 kmod-usb-storage
+DEFAULT_PACKAGES += kmod-usb3 kmod-usb-dwc3 kmod-usb-storage \
+  partx-utils
 
 $(eval $(call BuildTarget))