layerscape: support sysupgrade for SD card ext4 rootfs
[openwrt/staging/mkresin.git] / target / linux / layerscape / Makefile
index 3def184b948bde18b7d5b6533797e9cc8b8d8d51..c5b27ad0c7c33adafe4dda551888f0186dcfd7d2 100644 (file)
@@ -8,19 +8,17 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=layerscape
 BOARDNAME:=NXP Layerscape
-DEVICE_TYPE:=developerboard
-KERNEL_PATCHVER:=4.4
-KERNELNAME:=Image dtbs
-FEATURES:=squashfs nand usb pcie gpio
-SUBTARGETS:=64b 32b
-MAINTAINER:=Yangbo Lu <yangbo.lu@nxp.com>
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=5.4
+FEATURES:=squashfs nand usb pcie gpio fpu ubifs ext4
+SUBTARGETS:=armv8_64b armv7
 
 define Target/Description
-       Build firmware images for $(BOARDNAME) SoC devices.
+       Build firmware images for NXP Layerscape based boards.
 endef
 
-DEFAULT_PACKAGES += kmod-usb3 kmod-usb-dwc3 kmod-usb-storage
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += kmod-usb3 kmod-usb-dwc3 kmod-usb-storage \
+  partx-utils
 
 $(eval $(call BuildTarget))