layerscape: add kernel 5.10 as testing version
[openwrt/openwrt.git] / target / linux / layerscape / Makefile
index c5b27ad0c7c33adafe4dda551888f0186dcfd7d2..8b8ca29317d316b12d611f46917d820ed1d48cee 100644 (file)
@@ -1,15 +1,14 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2016 Jiang Yutang <jiangyutang1978@gmail.com>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 BOARD:=layerscape
 BOARDNAME:=NXP Layerscape
 KERNEL_PATCHVER:=5.4
-FEATURES:=squashfs nand usb pcie gpio fpu ubifs ext4
+KERNEL_TESTING_PATCHVER:=5.10
+FEATURES:=squashfs nand usb pcie gpio fpu ubifs ext4 rootfs-part boot-part
 SUBTARGETS:=armv8_64b armv7
 
 define Target/Description
@@ -19,6 +18,6 @@ endef
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += kmod-usb3 kmod-usb-dwc3 kmod-usb-storage \
-  partx-utils
+  mkf2fs e2fsprogs partx-utils
 
 $(eval $(call BuildTarget))