build: unify target independent optimization options
[openwrt/staging/jow.git] / target / linux / lantiq / Makefile
index f87d3d6274d0445af10e462c1823f1c7c55804d8..94b506d4eec539e5bde5949fd50d9c5826df9fb1 100644 (file)
@@ -8,14 +8,12 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=lantiq
 BOARDNAME:=Lantiq GPON/XWAY/SVIP
-FEATURES:=squashfs jffs2
-SUBTARGETS:=danube ar9 vr9 falcon svip_be
-LINUX_VERSION:=3.3.8
+FEATURES:=squashfs
+SUBTARGETS=xway ase falcon
 
-#SUBTARGETS=xway ase
-#LINUX_VERSION:=3.6.7
+LINUX_VERSION:=3.8.13
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CFLAGS=-Os -pipe -mips32r2 -mno-branch-likely
 
 define Target/Description
        Build firmware images for Lantiq SoC