orion: remove unmaintained target
[openwrt/openwrt.git] / target / linux / ixp4xx / modules.mk
index 8bf6e693b7893a2460d7ddb8377b4c7f4473f510..2d6446c05bfd593da1f19de883f5d5afe5d41bc1 100644 (file)
@@ -25,7 +25,7 @@ $(eval $(call KernelPackage,ata-ixp4xx-cf))
 define KernelPackage/ixp4xx-beeper
   SUBMENU:=$(OTHER_MENU)
   TITLE:=IXP4XX Beeper support
-  DEPENDS:=@TARGET_ixp4xx
+  DEPENDS:=@TARGET_ixp4xx +kmod-input-core
   KCONFIG:= \
        CONFIG_INPUT_MISC=y \
        CONFIG_INPUT_IXP4XX_BEEPER
@@ -56,3 +56,19 @@ define KernelPackage/crypto-hw-ixp4xx/description
 endef
 
 $(eval $(call KernelPackage,crypto-hw-ixp4xx))
+
+
+define KernelPackage/ixp4xx-eth
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=IXP4xxt Ethernet Adapter kernel support
+  DEPENDS:=@TARGET_ixp4xx
+  KCONFIG:=CONFIG_IXP4XX_ETH
+  FILES:=$(LINUX_DIR)/drivers/net/ethernet/xscale/ixp4xx_eth.ko
+  AUTOLOAD:=$(call AutoLoad,50,ixp4xx_eth)
+endef
+
+define KernelPackage/ixp4xx-eth/description
+ Kernel modules for Intel IXP4xx Ethernet chipsets.
+endef
+
+$(eval $(call KernelPackage,ixp4xx-eth))