ipq807x: add initial support for prpl Foundation Haze board
[openwrt/staging/hauke.git] / target / linux / ipq807x / image / generic.mk
index 1ea42845f01d35ee06e2cf6711691df1dc537646..92a1e37828adf26a37e1d98735a2943aa43b38da 100644 (file)
@@ -108,6 +108,18 @@ define Device/netgear_wax218
 endef
 TARGET_DEVICES += netgear_wax218
 
+define Device/prpl_haze
+       $(call Device/FitImage)
+       $(call Device/EmmcImage)
+       DEVICE_VENDOR := prpl Foundation
+       DEVICE_MODEL := Haze
+       DEVICE_DTS_CONFIG := config@hk09
+       SOC := ipq8072
+       DEVICE_PACKAGES += ath11k-firmware-qcn9074 ipq-wifi-prpl_haze kmod-ath11k-pci
+       DEFAULT_PACKAGES += ath11k-firmware-qcn9074 ipq-wifi-prpl_haze kmod-ath11k-pci
+endef
+TARGET_DEVICES += prpl_haze
+
 define Device/qnap_301w
        $(call Device/FitImage)
        $(call Device/EmmcImage)