CI: build-tools: build all host tools
[openwrt/staging/jow.git] / target / linux / ipq807x / image / generic.mk
index 23260ed1e784a6023d7886a0535acf2e6c59173d..6003f2a5c0e4823ce1ec758815ef0a24b0a08d7b 100644 (file)
@@ -10,6 +10,12 @@ define Device/FitImageLzma
        KERNEL_NAME := Image
 endef
 
+define Device/EmmcImage
+       IMAGES += factory.bin sysupgrade.bin
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 64k
+       IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to 64k | sysupgrade-tar rootfs=$$$$@ | append-metadata
+endef
+
 define Device/UbiFit
        KERNEL_IN_UBI := 1
        IMAGES := factory.ubi sysupgrade.bin
@@ -17,6 +23,46 @@ define Device/UbiFit
        IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
 endef
 
+define Device/buffalo_wxr-5950ax12
+       $(call Device/FitImage)
+       DEVICE_VENDOR := Buffalo
+       DEVICE_MODEL := WXR-5950AX12
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       DEVICE_DTS_CONFIG := config@hk01
+       SOC := ipq8074
+       IMAGES := sysupgrade.bin
+       IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+       DEVICE_PACKAGES := ipq-wifi-buffalo_wxr-5950ax12
+endef
+TARGET_DEVICES += buffalo_wxr-5950ax12
+
+define Device/compex_wpq873
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_VENDOR := Compex
+       DEVICE_MODEL := WPQ873
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       DEVICE_DTS_CONFIG := config@hk09.wpq873
+       SOC := ipq8072
+       IMAGE/factory.ubi := append-ubi | qsdk-ipq-factory-nand
+endef
+TARGET_DEVICES += compex_wpq873
+
+define Device/dynalink_dl-wrx36
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_VENDOR := Dynalink
+       DEVICE_MODEL := DL-WRX36
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       DEVICE_DTS_CONFIG := config@rt5010w-d350-rev0
+       SOC := ipq8072
+       DEVICE_PACKAGES := ipq-wifi-dynalink_dl-wrx36
+endef
+TARGET_DEVICES += dynalink_dl-wrx36
+
 define Device/edgecore_eap102
        $(call Device/FitImage)
        $(call Device/UbiFit)
@@ -44,18 +90,43 @@ define Device/edimax_cax1800
 endef
 TARGET_DEVICES += edimax_cax1800
 
+define Device/netgear_wax218
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       ARTIFACTS := web-ui-factory.fit
+       DEVICE_VENDOR := Netgear
+       DEVICE_MODEL := WAX218
+       DEVICE_DTS_CONFIG := config@hk07
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       SOC := ipq8072
+       ARTIFACT/web-ui-factory.fit := append-image initramfs-uImage.itb | \
+               ubinize-kernel | qsdk-ipq-factory-nand
+       DEVICE_PACKAGES := kmod-spi-gpio kmod-spi-bitbang kmod-gpio-nxp-74hc164 \
+               ipq-wifi-netgear_wax218
+endef
+TARGET_DEVICES += netgear_wax218
+
+define Device/prpl_haze
+       $(call Device/FitImage)
+       $(call Device/EmmcImage)
+       DEVICE_VENDOR := prpl Foundation
+       DEVICE_MODEL := Haze
+       DEVICE_DTS_CONFIG := config@hk09
+       SOC := ipq8072
+       DEVICE_PACKAGES += ath11k-firmware-qcn9074 ipq-wifi-prpl_haze kmod-ath11k-pci
+endef
+TARGET_DEVICES += prpl_haze
+
 define Device/qnap_301w
        $(call Device/FitImage)
+       $(call Device/EmmcImage)
        DEVICE_VENDOR := QNAP
        DEVICE_MODEL := 301w
        DEVICE_DTS_CONFIG := config@hk01
        KERNEL_SIZE := 16384k
-       BLOCKSIZE := 512k
        SOC := ipq8072
-       IMAGES += factory.bin sysupgrade.bin
-       IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 64k
-       IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to 64k | sysupgrade-tar rootfs=$$$$@ | append-metadata
-       DEVICE_PACKAGES := ipq-wifi-qnap_301w e2fsprogs kmod-fs-ext4 losetup
+       DEVICE_PACKAGES += ipq-wifi-qnap_301w
 endef
 TARGET_DEVICES += qnap_301w
 
@@ -103,3 +174,15 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
 endif
 endef
 TARGET_DEVICES += xiaomi_ax9000
+
+define Device/zyxel_nbg7815
+       $(call Device/FitImage)
+       $(call Device/EmmcImage)
+       DEVICE_VENDOR := ZYXEL
+       DEVICE_MODEL := NBG7815
+       DEVICE_DTS_CONFIG := config@nbg7815
+       SOC := ipq8074
+       DEVICE_PACKAGES += ipq-wifi-zyxel_nbg7815 kmod-ath11k-pci kmod-hwmon-tmp103 \
+               kmod-bluetooth
+endef
+TARGET_DEVICES += zyxel_nbg7815