ipq806x: sync config-6.1 with latest kernel
[openwrt/openwrt.git] / target / linux / ipq806x / modules.mk
index 6f1ca2d2a4380eea85f1c5c4fcb73bfd55d81e88..a2b844d0f03cc3cbd64efa0ff480504bc23c140e 100644 (file)
@@ -1,31 +1,45 @@
-define KernelPackage/usb-dwc3-of-simple
-  TITLE:=DWC3 USB simple OF driver
-  DEPENDS:=+kmod-usb-dwc3
-  KCONFIG:= CONFIG_USB_DWC3_OF_SIMPLE
-  FILES:= $(LINUX_DIR)/drivers/usb/dwc3/dwc3-of-simple.ko
-  AUTOLOAD:=$(call AutoLoad,53,dwc3-of-simple,1)
+define KernelPackage/phy-qcom-ipq806x-usb
+  TITLE:=Qualcomm IPQ806x DWC3 USB PHY driver
+  DEPENDS:=@TARGET_ipq806x
+  KCONFIG:= CONFIG_PHY_QCOM_IPQ806X_USB
+  FILES:= \
+    $(LINUX_DIR)/drivers/phy/qualcomm/phy-qcom-ipq806x-usb.ko
+  AUTOLOAD:=$(call AutoLoad,45,phy-qcom-ipq806x-usb,1)
   $(call AddDepends/usb)
 endef
 
-define KernelPackage/usb-dwc3-of-simple/description
- This driver provides generic platform glue for the integrated DesignWare
- USB3 IP Core.
+define KernelPackage/phy-qcom-ipq806x-usb/description
+ This driver provides support for the integrated DesignWare
+ USB3 IP Core within the QCOM SoCs.
 endef
 
-$(eval $(call KernelPackage,usb-dwc3-of-simple))
+$(eval $(call KernelPackage,phy-qcom-ipq806x-usb))
 
-define KernelPackage/usb-phy-qcom-dwc3
-  TITLE:=DWC3 USB QCOM PHY driver
-  DEPENDS:=@TARGET_ipq806x +kmod-usb-dwc3-of-simple
-  KCONFIG:= CONFIG_PHY_QCOM_DWC3
-  FILES:= $(LINUX_DIR)/drivers/phy/phy-qcom-dwc3.ko
-  AUTOLOAD:=$(call AutoLoad,45,phy-qcom-dwc3,1)
-  $(call AddDepends/usb)
+
+define KernelPackage/sound-soc-ipq8064-storm
+  TITLE:=Qualcomm IPQ8064 SoC support for Google Storm
+  DEPENDS:=@TARGET_ipq806x +kmod-sound-soc-core
+  KCONFIG:=\
+       CONFIG_IPQ_LCC_806X \
+       CONFIG_SND_SOC_QCOM \
+       CONFIG_SND_SOC_STORM \
+       CONFIG_SND_SOC_APQ8016_SBC=n \
+       CONFIG_SND_SOC_SC7180=n
+  FILES:=\
+       $(LINUX_DIR)/drivers/clk/qcom/lcc-ipq806x.ko \
+       $(LINUX_DIR)/sound/soc/codecs/snd-soc-max98357a.ko \
+       $(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-cpu.ko \
+       $(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-ipq806x.ko \
+       $(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-platform.ko \
+       $(LINUX_DIR)/sound/soc/qcom/snd-soc-storm.ko
+  AUTOLOAD:=$(call AutoProbe,lcc-ipq806x \
+       snd-soc-max98357a snd-soc-lpass-ipq806x snd-soc-storm)
+  $(call AddDepends/sound)
 endef
 
-define KernelPackage/usb-phy-qcom-dwc3/description
- This driver provides support for the integrated DesignWare
USB3 IP Core within the QCOM SoCs.
+define KernelPackage/sound-soc-ipq8064-storm/description
+ Provides sound support for the Google Storm platform, with a Qualcomm IPQ8064
SoC.
 endef
 
-$(eval $(call KernelPackage,usb-phy-qcom-dwc3))
+$(eval $(call KernelPackage,sound-soc-ipq8064-storm))