ipq806x: remove dangling ipq-wifi-edgecore_ecw5410
[openwrt/staging/pepe2k.git] / target / linux / ipq806x / image / generic.mk
index 44e0df1b3f91abd7b6d181af07956b8974e62c4c..b83999dd00ed6c3a33b3003b6f4de2a21f451aa6 100644 (file)
@@ -141,8 +141,7 @@ define Device/edgecore_ecw5410
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        DEVICE_DTS_CONFIG := config@v2.0-ap160
-       DEVICE_PACKAGES := ath10k-firmware-qca9984-ct \
-               ipq-wifi-edgecore_ecw5410
+       DEVICE_PACKAGES := ath10k-firmware-qca9984-ct
 endef
 TARGET_DEVICES += edgecore_ecw5410
 
@@ -163,7 +162,6 @@ define Device/linksys_ea7500-v1
        IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | \
                append-ubi | pad-to $$$$(PAGESIZE)
        DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
-       DEFAULT := n
 endef
 TARGET_DEVICES += linksys_ea7500-v1
 
@@ -336,6 +334,20 @@ define Device/netgear_xr500
 endef
 TARGET_DEVICES += netgear_xr500
 
+define Device/nokia_ac400i
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_VENDOR := Nokia
+       DEVICE_MODEL := AC400i
+       SOC := qcom-ipq8065
+       DEVICE_DTS := qcom-ipq8065-ac400i
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       BOARD_NAME := ac400i
+       DEVICE_PACKAGES := ath10k-firmware-qca9984-ct
+endef
+TARGET_DEVICES += nokia_ac400i
+
 define Device/qcom_ipq8064-ap148
        $(call Device/FitImage)
        $(call Device/UbiFit)