ipq806x: add kernel 6.6 as a testing kernel version
[openwrt/openwrt.git] / target / linux / ipq806x / Makefile
index f07c87dbbdda3cc6c1e25912ea3af7630c672b2c..cd6f3dc2d3b4e231d2a4246c3049c84be910ba9d 100644 (file)
@@ -5,14 +5,23 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=ipq806x
 BOARDNAME:=Qualcomm Atheros IPQ806X
-FEATURES:=squashfs
-CPU_TYPE:=cortex-a7
-MAINTAINER:=John Crispin <blogic@openwrt.org>
+FEATURES:=squashfs fpu ramdisk
+CPU_TYPE:=cortex-a15
+CPU_SUBTYPE:=neon-vfpv4
+SUBTARGETS:=generic chromium
 
-KERNEL_PATCHVER:=3.18
+KERNEL_PATCHVER:=6.1
+KERNEL_TESTING_PATCHVER:=6.6
 
-KERNELNAME:=Image dtbs
+KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug \
+       kmod-ata-ahci kmod-ata-ahci-platform \
+       kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
+       kmod-phy-qcom-ipq806x-usb kmod-usb3 kmod-usb-dwc3-qcom \
+       kmod-ath10k-ct wpad-basic-mbedtls \
+       uboot-envtools
 
 $(eval $(call BuildTarget))