ipq806x: add kernel 6.6 as a testing kernel version
[openwrt/openwrt.git] / target / linux / ipq806x / Makefile
index 69d3aa1e569d79a9436bf14035063986cc12c5e4..cd6f3dc2d3b4e231d2a4246c3049c84be910ba9d 100644 (file)
@@ -5,22 +5,23 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=ipq806x
 BOARDNAME:=Qualcomm Atheros IPQ806X
-FEATURES:=squashfs nand fpu ramdisk
+FEATURES:=squashfs fpu ramdisk
 CPU_TYPE:=cortex-a15
 CPU_SUBTYPE:=neon-vfpv4
-SUBTARGETS:=generic
+SUBTARGETS:=generic chromium
 
-KERNEL_PATCHVER:=5.4
+KERNEL_PATCHVER:=6.1
+KERNEL_TESTING_PATCHVER:=6.6
 
 KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
+       kmod-leds-gpio kmod-gpio-button-hotplug \
        kmod-ata-ahci kmod-ata-ahci-platform \
        kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
        kmod-phy-qcom-ipq806x-usb kmod-usb3 kmod-usb-dwc3-qcom \
-       kmod-ath10k-ct wpad-basic-wolfssl \
+       kmod-ath10k-ct wpad-basic-mbedtls \
        uboot-envtools
 
 $(eval $(call BuildTarget))