kernel: bump 6.1 to 6.1.59
[openwrt/openwrt.git] / target / linux / ipq806x / Makefile
index 875bb9cee917c8d76bc96389453a53cc5aa7a2d7..1bcea1fa80fdd6b840abd7f6ebd5f0d8eb2180ac 100644 (file)
@@ -5,14 +5,22 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=ipq806x
 BOARDNAME:=Qualcomm Atheros IPQ806X
-FEATURES:=squashfs
-CPU_TYPE:=cortex-a7
-MAINTAINER:=John Crispin <blogic@openwrt.org>
+FEATURES:=squashfs fpu ramdisk
+CPU_TYPE:=cortex-a15
+CPU_SUBTYPE:=neon-vfpv4
+SUBTARGETS:=generic chromium
 
-KERNEL_PATCHVER:=3.14
+KERNEL_PATCHVER:=6.1
 
-KERNELNAME:=Image dtbs
+KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug \
+       kmod-ata-ahci kmod-ata-ahci-platform \
+       kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
+       kmod-phy-qcom-ipq806x-usb kmod-usb3 kmod-usb-dwc3-qcom \
+       kmod-ath10k-ct wpad-basic-mbedtls \
+       uboot-envtools ip-tiny
 
 $(eval $(call BuildTarget))