ipq806x: 6.1: manually refresh kernel patches
[openwrt/openwrt.git] / target / linux / ipq806x / Makefile
index 24409d67191dd5a585ef3b32d36dbcf332913a8b..057446f75571f60f0a1dec697f8753ff17b3e1c3 100644 (file)
@@ -5,23 +5,22 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=ipq806x
 BOARDNAME:=Qualcomm Atheros IPQ806X
-FEATURES:=squashfs nand fpu ramdisk
+FEATURES:=squashfs fpu ramdisk
 CPU_TYPE:=cortex-a15
 CPU_SUBTYPE:=neon-vfpv4
-MAINTAINER:=John Crispin <john@phrozen.org>
-SUBTARGETS:=generic
+SUBTARGETS:=generic chromium
 
-KERNEL_PATCHVER:=4.19
+KERNEL_PATCHVER:=5.15
 
 KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
        kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
-       kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform \
+       kmod-ata-ahci kmod-ata-ahci-platform \
        kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
-       kmod-usb-phy-qcom-dwc3 kmod-usb3 kmod-usb-dwc3-qcom \
-       kmod-ath10k-ct wpad-basic \
+       kmod-phy-qcom-ipq806x-usb kmod-usb3 kmod-usb-dwc3-qcom \
+       kmod-ath10k-ct wpad-basic-mbedtls \
        uboot-envtools
 
 $(eval $(call BuildTarget))