ipq40xx: 6.6: refresh kernel patches
[openwrt/staging/nbd.git] / target / linux / ipq40xx / patches-6.6 / 850-soc-add-qualcomm-syscon.patch
index 80dba5d686c8f5be1a32bab96250b7e34f43531b..778b9f59303b121b6f5c33a7b14f29d955b8209f 100644 (file)
@@ -2,9 +2,9 @@ From: Christian Lamparter <chunkeey@googlemail.com>
 Subject: SoC: add qualcomm syscon
 --- a/drivers/soc/qcom/Kconfig
 +++ b/drivers/soc/qcom/Kconfig
-@@ -248,4 +248,11 @@ config QCOM_ICC_BWMON
-         the fixed bandwidth votes from cpufreq (CPU nodes) thus achieve high
-         memory throughput even with lower CPU frequencies.
+@@ -291,4 +291,11 @@ config QCOM_INLINE_CRYPTO_ENGINE
+       tristate
+       select QCOM_SCM
  
 +config QCOM_TCSR
 +      tristate "QCOM Top Control and Status Registers"
@@ -16,7 +16,7 @@ Subject: SoC: add qualcomm syscon
  endmenu
 --- a/drivers/soc/qcom/Makefile
 +++ b/drivers/soc/qcom/Makefile
-@@ -29,3 +29,4 @@ obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o
+@@ -32,3 +32,4 @@ obj-$(CONFIG_QCOM_KRYO_L2_ACCESSORS) +=
  obj-$(CONFIG_QCOM_ICC_BWMON)  += icc-bwmon.o
  qcom_ice-objs                 += ice.o
  obj-$(CONFIG_QCOM_INLINE_CRYPTO_ENGINE)       += qcom_ice.o