image: use helper function for size units
[openwrt/staging/hauke.git] / target / linux / ipq40xx / image / generic.mk
index b22d261d659a73bb8503a370ca43fa53a77077d5..b4719033c0a54e8531207967286984359fdf1786 100644 (file)
@@ -4,28 +4,28 @@ DEVICE_VARS += RAS_BOARD RAS_ROOTFS_SIZE RAS_VERSION
 DEVICE_VARS += WRGG_DEVNAME WRGG_SIGNATURE
 
 define Device/FitImage
-       KERNEL_SUFFIX := -fit-uImage.itb
-       KERNEL = kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
+       KERNEL_SUFFIX := -uImage.itb
+       KERNEL = kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
        KERNEL_NAME := Image
 endef
 
 define Device/FitImageLzma
-       KERNEL_SUFFIX := -fit-uImage.itb
-       KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb
+       KERNEL_SUFFIX := -uImage.itb
+       KERNEL = kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(DEVICE_DTS).dtb
        KERNEL_NAME := Image
 endef
 
 define Device/FitzImage
-       KERNEL_SUFFIX := -fit-zImage.itb
-       KERNEL = kernel-bin | fit none $$(DTS_DIR)/$$(DEVICE_DTS).dtb
+       KERNEL_SUFFIX := -zImage.itb
+       KERNEL = kernel-bin | fit none $$(KDIR)/image-$$(DEVICE_DTS).dtb
        KERNEL_NAME := zImage
 endef
 
 define Device/UbiFit
        KERNEL_IN_UBI := 1
-       IMAGES := nand-factory.ubi nand-sysupgrade.bin
-       IMAGE/nand-factory.ubi := append-ubi
-       IMAGE/nand-sysupgrade.bin := sysupgrade-tar | append-metadata
+       IMAGES := factory.ubi sysupgrade.bin
+       IMAGE/factory.ubi := append-ubi
+       IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
 endef
 
 define Device/DniImage
@@ -43,7 +43,8 @@ define Build/append-rootfshdr
                -O linux -T filesystem \
                -C lzma -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
                -n root.squashfs -d $(IMAGE_ROOTFS) $@.new
-       dd if=$@.new bs=64 count=1 >> $(IMAGE_KERNEL)
+       cat $(IMAGE_KERNEL) > $@.$1
+       dd if=$@.new bs=64 count=1 >> $@.$1
 endef
 
 define Build/append-rutx-metadata
@@ -67,7 +68,7 @@ define Build/mkmylofw_32m
 
        let \
                size="$$(stat -c%s $@)" \
-               pad="$(subst k,* 1024,$(BLOCKSIZE))" \
+               pad="$(call exp_units,$(BLOCKSIZE))" \
                pad="(pad - (size % pad)) % pad" \
                newsize='size + pad'; \
                $(STAGING_DIR_HOST)/bin/mkmylofw \
@@ -89,7 +90,7 @@ endef
 
 define Build/qsdk-ipq-factory-nand-askey
        $(TOPDIR)/scripts/mkits-qsdk-ipq-image.sh $@.its\
-               askey_kernel $(IMAGE_KERNEL) \
+               askey_kernel $@.$1 \
                askey_fs $(IMAGE_ROOTFS) \
                ubifs $@
        PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $@.its $@.new
@@ -130,7 +131,6 @@ define Device/8dev_habanero-dvk
        DEVICE_MODEL := Habanero DVK
        IMAGE_SIZE := 30976k
        SOC := qcom-ipq4019
-       DEVICE_PACKAGES := ipq-wifi-8dev_habanero-dvk
        IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | check-size | append-metadata
 endef
 TARGET_DEVICES += 8dev_habanero-dvk
@@ -160,8 +160,8 @@ define Device/alfa-network_ap120c-ac
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        IMAGE_SIZE := 65536k
-       IMAGES := nand-factory.bin nand-sysupgrade.bin
-       IMAGE/nand-factory.bin := append-ubi | qsdk-ipq-factory-nand
+       IMAGES := factory.bin sysupgrade.bin
+       IMAGE/factory.bin := append-ubi | qsdk-ipq-factory-nand
 endef
 TARGET_DEVICES += alfa-network_ap120c-ac
 
@@ -169,7 +169,6 @@ define Device/aruba_glenmorangie
        $(call Device/FitImageLzma)
        DEVICE_VENDOR := Aruba
        SOC := qcom-ipq4029
-       DEVICE_PACKAGES := ipq-wifi-aruba_ap-303
 endef
 
 define Device/aruba_ap-303
@@ -187,7 +186,7 @@ TARGET_DEVICES += aruba_ap-303h
 define Device/aruba_ap-365
        $(call Device/aruba_glenmorangie)
        DEVICE_MODEL := AP-365
-       DEVICE_PACKAGES += kmod-hwmon-ad7418
+       DEVICE_PACKAGES := kmod-hwmon-ad7418
 endef
 TARGET_DEVICES += aruba_ap-365
 
@@ -214,6 +213,8 @@ define Device/asus_rt-ac42u
        DEVICE_MODEL := RT-AC42U
        DEVICE_ALT0_VENDOR := ASUS
        DEVICE_ALT0_MODEL := RT-ACRH17
+       DEVICE_ALT1_VENDOR := ASUS
+       DEVICE_ALT1_MODEL := RT-AC2200
        SOC := qcom-ipq4019
        BLOCKSIZE := 128k
        PAGESIZE := 2048
@@ -223,7 +224,7 @@ define Device/asus_rt-ac42u
 #      Rather, this device is a/k/a RT-AC42U
 #      But we'll go with what the vendor firmware has...
        UIMAGE_NAME:=$(shell echo -e '\03\01\01\01RT-AC82U')
-       DEVICE_PACKAGES := ath10k-firmware-qca9984-ct ipq-wifi-asus_rt-ac42u kmod-usb-ledtrig-usbport
+       DEVICE_PACKAGES := ath10k-firmware-qca9984-ct kmod-usb-ledtrig-usbport
 endef
 TARGET_DEVICES += asus_rt-ac42u
 
@@ -269,8 +270,10 @@ define Device/avm_fritzbox-7530
        $(call Device/FitImageLzma)
        DEVICE_VENDOR := AVM
        DEVICE_MODEL := FRITZ!Box 7530
+       DEVICE_ALT0_VENDOR := AVM
+       DEVICE_ALT0_MODEL := FRITZ!Box 7520
        SOC := qcom-ipq4019
-       DEVICE_PACKAGES := fritz-caldata fritz-tffs-nand
+       DEVICE_PACKAGES := fritz-caldata fritz-tffs-nand ltq-vdsl-vr11-app
 endef
 TARGET_DEVICES += avm_fritzbox-7530
 
@@ -279,7 +282,7 @@ define Device/avm_fritzrepeater-1200
        DEVICE_VENDOR := AVM
        DEVICE_MODEL := FRITZ!Repeater 1200
        SOC := qcom-ipq4019
-       DEVICE_PACKAGES := fritz-caldata fritz-tffs-nand ipq-wifi-avm_fritzrepeater-1200
+       DEVICE_PACKAGES := fritz-caldata fritz-tffs-nand
 endef
 TARGET_DEVICES += avm_fritzrepeater-1200
 
@@ -298,21 +301,21 @@ define Device/buffalo_wtr-m2133hp
        DEVICE_VENDOR := Buffalo
        DEVICE_MODEL := WTR-M2133HP
        SOC := qcom-ipq4019
-       DEVICE_PACKAGES := ath10k-firmware-qca9984-ct ipq-wifi-buffalo_wtr-m2133hp
+       DEVICE_PACKAGES := ath10k-firmware-qca9984-ct
        BLOCKSIZE := 128k
        PAGESIZE := 2048
 endef
 TARGET_DEVICES += buffalo_wtr-m2133hp
 
 define Device/cellc_rtl30vw
-       KERNEL_SUFFIX := -fit-zImage.itb
-       KERNEL_INITRAMFS = kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
-       KERNEL = kernel-bin | fit none $$(DTS_DIR)/$$(DEVICE_DTS).dtb | uImage lzma | pad-to 2048
+       KERNEL_SUFFIX := -zImage.itb
+       KERNEL_INITRAMFS = kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
+       KERNEL = kernel-bin | fit none $$(KDIR)/image-$$(DEVICE_DTS).dtb | uImage lzma | pad-to 2048
        KERNEL_NAME := zImage
        KERNEL_IN_UBI :=
-       IMAGES := nand-factory.bin nand-sysupgrade.bin
-       IMAGE/nand-factory.bin := append-rootfshdr | append-ubi | qsdk-ipq-factory-nand-askey
-       IMAGE/nand-sysupgrade.bin := append-rootfshdr | sysupgrade-tar | append-metadata
+       IMAGES := factory.bin sysupgrade.bin
+       IMAGE/factory.bin := append-rootfshdr kernel | append-ubi | qsdk-ipq-factory-nand-askey kernel
+       IMAGE/sysupgrade.bin := append-rootfshdr kernel | sysupgrade-tar kernel=$$$$@.kernel | append-metadata
        DEVICE_VENDOR := Cell C
        DEVICE_MODEL := RTL30VW
        SOC := qcom-ipq4019
@@ -322,7 +325,7 @@ define Device/cellc_rtl30vw
        IMAGE_SIZE := 57344k
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi ipq-wifi-cellc_rtl30vw
+       DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
 endef
 TARGET_DEVICES += cellc_rtl30vw
 
@@ -330,9 +333,10 @@ define Device/cilab_meshpoint-one
        $(call Device/8dev_jalapeno-common)
        DEVICE_VENDOR := Crisis Innovation Lab
        DEVICE_MODEL := MeshPoint.One
-       DEVICE_PACKAGES := kmod-i2c-gpio kmod-iio-bmp280-i2c kmod-hwmon-ina2xx kmod-rtc-pcf2127
+       DEVICE_PACKAGES += kmod-i2c-gpio kmod-iio-bmp280-i2c kmod-hwmon-ina2xx kmod-rtc-pcf2127
 endef
-TARGET_DEVICES += cilab_meshpoint-one
+# Missing DSA Setup
+#TARGET_DEVICES += cilab_meshpoint-one
 
 define Device/compex_wpj419
        $(call Device/FitImage)
@@ -346,10 +350,11 @@ define Device/compex_wpj419
        PAGESIZE := 2048
        FILESYSTEMS := squashfs
 endef
-TARGET_DEVICES += compex_wpj419
+# Missing DSA Setup
+#TARGET_DEVICES += compex_wpj419
 
 define Device/compex_wpj428
-       $(call Device/FitImage)
+       $(call Device/FitzImage)
        DEVICE_VENDOR := Compex
        DEVICE_MODEL := WPJ428
        SOC := qcom-ipq4028
@@ -366,7 +371,7 @@ endef
 TARGET_DEVICES += compex_wpj428
 
 define Device/devolo_magic-2-wifi-next
-       $(call Device/FitImage)
+       $(call Device/FitzImage)
        DEVICE_VENDOR := devolo
        DEVICE_MODEL := Magic 2 WiFi next
        SOC := qcom-ipq4018
@@ -374,13 +379,12 @@ define Device/devolo_magic-2-wifi-next
 
        # If the bootloader sees 0xDEADC0DE and this trailer at the 64k boundary of a TFTP image
        # it will bootm it, just like we want for the initramfs.
-       KERNEL_INITRAMFS := kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb | pad-to 64k |\
+       KERNEL_INITRAMFS := kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb | pad-to 64k |\
                append-string -e '\xDE\xAD\xC0\xDE{"fl_initramfs":""}\x00'
 
        IMAGE_SIZE := 26624k
        IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := ipq-wifi-devolo_magic-2-wifi-next
        DEFAULT := n
 endef
 TARGET_DEVICES += devolo_magic-2-wifi-next
@@ -408,7 +412,6 @@ define Device/dlink_dap-2610
        # append-rootfs must start on an erase block boundary.
        IMAGE/factory.bin    := append-kernel | pad-offset 6144k 160 | append-rootfs | wrgg-image | check-size
        IMAGE/sysupgrade.bin := append-kernel | wrgg-image | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size | append-metadata
-       DEVICE_PACKAGES := ipq-wifi-dlink_dap2610
 endef
 TARGET_DEVICES += dlink_dap-2610
 
@@ -433,11 +436,12 @@ define Device/edgecore_oap100
        SOC := qcom-ipq4019
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       IMAGES := nand-sysupgrade.bin
+       IMAGES := sysupgrade.bin
        DEVICE_DTS_CONFIG := config@ap.dk07.1-c1
-       DEVICE_PACKAGES := ipq-wifi-edgecore_oap100 kmod-usb-acm kmod-usb-net kmod-usb-net-cdc-qmi uqmi
+       DEVICE_PACKAGES := kmod-usb-acm kmod-usb-net kmod-usb-net-cdc-qmi uqmi
 endef
-TARGET_DEVICES += edgecore_oap100
+# Missing DSA Setup
+#TARGET_DEVICES += edgecore_oap100
 
 define Device/engenius_eap1300
        $(call Device/FitImage)
@@ -450,7 +454,8 @@ define Device/engenius_eap1300
        IMAGE_SIZE := 25344k
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
 endef
-TARGET_DEVICES += engenius_eap1300
+# Missing DSA Setup
+#TARGET_DEVICES += engenius_eap1300
 
 define Device/engenius_eap2200
        $(call Device/FitImage)
@@ -460,9 +465,10 @@ define Device/engenius_eap2200
        SOC := qcom-ipq4019
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-engenius_eap2200 -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
+       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
 endef
-TARGET_DEVICES += engenius_eap2200
+# Missing DSA Setup
+#TARGET_DEVICES += engenius_eap2200
 
 define Device/engenius_emd1
        $(call Device/FitImage)
@@ -474,9 +480,9 @@ define Device/engenius_emd1
        IMAGES += factory.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
        IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size
-       DEVICE_PACKAGES := ipq-wifi-engenius_emd1
 endef
-TARGET_DEVICES += engenius_emd1
+# Missing DSA Setup
+#TARGET_DEVICES += engenius_emd1
 
 define Device/engenius_emr3500
        $(call Device/FitImage)
@@ -489,10 +495,10 @@ define Device/engenius_emr3500
        IMAGES += factory.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
        IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size
-       DEVICE_PACKAGES := ipq-wifi-engenius_emr3500
        DEFAULT := n
 endef
-TARGET_DEVICES += engenius_emr3500
+# Missing DSA Setup
+#TARGET_DEVICES += engenius_emr3500
 
 define Device/engenius_ens620ext
        $(call Device/FitImage)
@@ -518,7 +524,29 @@ define Device/engenius_ens620ext
        IMAGE/factory_30.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size | SenaoFW $$$$(PRODUCT_ID) $$$$(FW_VER)
        IMAGE/factory_35.bin := qsdk-ipq-factory-nor | check-size | SenaoFW $$$$(PRODUCT_ID_NEW) $$$$(FW_VER_NEW)
 endef
-TARGET_DEVICES += engenius_ens620ext
+# Missing DSA Setup
+#TARGET_DEVICES += engenius_ens620ext
+
+define Device/extreme-networks_ws-ap3915i
+       $(call Device/FitImage)
+       DEVICE_VENDOR := Extreme Networks
+       DEVICE_MODEL := WS-AP3915i
+       IMAGE_SIZE := 30080k
+       SOC := qcom-ipq4029
+       BLOCKSIZE := 128k
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size | append-metadata
+endef
+TARGET_DEVICES += extreme-networks_ws-ap3915i
+
+define Device/extreme-networks_ws-ap391x
+       $(call Device/FitImage)
+       DEVICE_VENDOR := Extreme Networks
+       DEVICE_MODEL := WS-AP391x
+       IMAGE_SIZE := 15040k
+       SOC := qcom-ipq4029
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size | append-metadata
+endef
+TARGET_DEVICES += extreme-networks_ws-ap391x
 
 define Device/ezviz_cs-w3-wd1200g-eup
        $(call Device/FitImage)
@@ -530,14 +558,26 @@ define Device/ezviz_cs-w3-wd1200g-eup
        SOC := qcom-ipq4018
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
                append-metadata
-       DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers \
-               ipq-wifi-ezviz_cs-w3-wd1200g-eup
+       DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
        DEVICE_COMPAT_VERSION := 2.0
        DEVICE_COMPAT_MESSAGE := uboot's bootcmd has to be updated (see wiki). \
                Upgrade via sysupgrade mechanism is not possible.
 endef
 TARGET_DEVICES += ezviz_cs-w3-wd1200g-eup
 
+define Device/glinet_gl-a1300
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_VENDOR := GL.iNet
+       DEVICE_MODEL := GL-A1300
+       SOC := qcom-ipq4018
+       DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       IMAGE_SIZE := 131072k
+endef
+TARGET_DEVICES += glinet_gl-a1300
+
 define Device/glinet_gl-ap1300
        $(call Device/FitImage)
        $(call Device/UbiFit)
@@ -549,7 +589,7 @@ define Device/glinet_gl-ap1300
        PAGESIZE := 2048
        IMAGE_SIZE := 131072k
        KERNEL_INSTALL := 1
-       DEVICE_PACKAGES := ipq-wifi-glinet_gl-ap1300
+       DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
 endef
 TARGET_DEVICES += glinet_gl-ap1300
 
@@ -578,7 +618,7 @@ define Device/glinet_gl-b2200
                pad-to 33792k | append-rootfs |\
                append-metadata | gzip
        IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
-       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-glinet_gl-b2200 \
+       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct \
                kmod-fs-ext4 kmod-mmc kmod-spi-dev mkf2fs e2fsprogs kmod-fs-f2fs
 endef
 TARGET_DEVICES += glinet_gl-b2200
@@ -592,9 +632,21 @@ define Device/glinet_gl-s1300
        IMAGE_SIZE := 26624k
        IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := ipq-wifi-glinet_gl-s1300 kmod-fs-ext4 kmod-mmc kmod-spi-dev
+       DEVICE_PACKAGES := kmod-fs-ext4 kmod-mmc kmod-spi-dev
+endef
+# Missing DSA Setup
+#TARGET_DEVICES += glinet_gl-s1300
+
+define Device/kernel-size-6350-8300
+       DEVICE_COMPAT_VERSION := 2.0
+       DEVICE_COMPAT_MESSAGE := Kernel partition size must be increased for \
+       this OpenWrt version. Before continuing, you MUST issue either the \
+       command "fw_setenv kernsize 500000" from the OpenWrt command line, \
+       or "setenv kernsize 500000 ; saveenv" from the U-Boot serial console. \
+       Instead of the sysupgrade image, you must then install the OpenWrt \
+       factory image, setting the force flag and wiping the configuration. \
+       (e.g. "sysupgrade -n -F openwrt-squashfs-factory.bin" on command line)
 endef
-TARGET_DEVICES += glinet_gl-s1300
 
 define Device/linksys_ea6350v3
        # The Linksys EA6350v3 has a uboot bootloader that does not
@@ -602,30 +654,32 @@ define Device/linksys_ea6350v3
        # partitions. This uboot, however, supports raw kernel images and
        # gzipped images.
        #
-       # As for the time of writing this, the device will boot the kernel
-       # from a fixed address with a fixed length of 3MiB. Also, the
-       # device has a hard-coded kernel command line that requieres the
+       # As configured by the OEM factory, the device will boot the kernel
+       # from a fixed address with a fixed length of 3 MiB. Also, the
+       # device has a hard-coded kernel command line that requires the
        # rootfs and alt_rootfs to be in mtd11 and mtd13 respectively.
        # Oh... and the kernel partition overlaps with the rootfs
        # partition (the same for alt_kernel and alt_rootfs).
        #
        # If you are planing re-partitioning the device, you may want to
-       # keep those details in mind:
-       # 1. The kernel adresses you should honor are 0x00000000 and
+       # keep these details in mind:
+       # 1. The kernel addresses you should honor are 0x00000000 and
        #    0x02800000 respectively.
-       # 2. The kernel size (plus the dtb) cannot exceed 3.00MiB in size.
+       # 2. The kernel size (plus the dtb) cannot exceed 3 MiB in size
+       #    unless the uboot environment variable "kernsize" is increased.
        # 3. You can use 'zImage', but not a raw 'Image' packed with lzma.
        # 4. The kernel command line from uboot is harcoded to boot with
        #    rootfs either in mtd11 or mtd13.
        $(call Device/FitzImage)
+       $(call Device/kernel-size-6350-8300)
        DEVICE_VENDOR := Linksys
        DEVICE_MODEL := EA6350
        DEVICE_VARIANT := v3
        SOC := qcom-ipq4018
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       KERNEL_SIZE := 3072k
-       IMAGE_SIZE := 37888k
+       KERNEL_SIZE := 5120k
+       IMAGE_SIZE := 35840k
        UBINIZE_OPTS := -E 5
        IMAGES += factory.bin
        IMAGE/factory.bin := append-kernel | append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=EA6350v3
@@ -634,59 +688,106 @@ TARGET_DEVICES += linksys_ea6350v3
 
 define Device/linksys_ea8300
        $(call Device/FitzImage)
+       $(call Device/kernel-size-6350-8300)
        DEVICE_VENDOR := Linksys
        DEVICE_MODEL := EA8300
        SOC := qcom-ipq4019
-       KERNEL_SIZE := 3072k
-       IMAGE_SIZE := 87040k
+       KERNEL_SIZE := 5120k
+       IMAGE_SIZE := 84992k
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        UBINIZE_OPTS := -E 5    # EOD marks to "hide" factory sig at EOF
        IMAGES += factory.bin
        IMAGE/factory.bin  := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=EA8300
-       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-linksys_ea8300 kmod-usb-ledtrig-usbport
+       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct kmod-usb-ledtrig-usbport
 endef
 TARGET_DEVICES += linksys_ea8300
 
 define Device/linksys_mr8300
        $(call Device/FitzImage)
+       $(call Device/kernel-size-6350-8300)
        DEVICE_VENDOR := Linksys
        DEVICE_MODEL := MR8300
        SOC := qcom-ipq4019
-       KERNEL_SIZE := 3072k
-       IMAGE_SIZE := 87040k
+       KERNEL_SIZE := 5120k
+       IMAGE_SIZE := 84992k
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        UBINIZE_OPTS := -E 5    # EOD marks to "hide" factory sig at EOF
        IMAGES += factory.bin
        IMAGE/factory.bin  := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=MR8300
-       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-linksys_mr8300-v0 kmod-usb-ledtrig-usbport
+       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct kmod-usb-ledtrig-usbport
 endef
 TARGET_DEVICES += linksys_mr8300
 
+define Device/linksys_whw03v2
+       $(call Device/FitzImage)
+       DEVICE_VENDOR := Linksys
+       DEVICE_MODEL := WHW03
+       DEVICE_VARIANT := V2
+       SOC := qcom-ipq4019
+       KERNEL_SIZE := 6144k
+       IMAGE_SIZE := 158720k
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       UBINIZE_OPTS := -E 5    # EOD marks to "hide" factory sig at EOF
+       IMAGES += factory.bin
+       IMAGE/factory.bin  := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=WHW03v2
+       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct kmod-leds-pca963x kmod-spi-dev kmod-bluetooth
+endef
+TARGET_DEVICES += linksys_whw03v2
+
+define Device/linksys_whw01
+       $(call Device/FitzImage)
+       DEVICE_VENDOR := Linksys
+       DEVICE_MODEL := WHW01
+       KERNEL_SIZE := 6144k
+       IMAGE_SIZE := 75776k
+       SOC := qcom-ipq4018
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       UBINIZE_OPTS := -E 5    # EOD marks to "hide" factory sig at EOF
+       IMAGES += factory.bin
+       IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=WHW01
+       DEVICE_PACKAGES := uboot-envtools kmod-leds-pca963x
+endef
+TARGET_DEVICES += linksys_whw01
+
 define Device/luma_wrtq-329acn
        $(call Device/FitImage)
        DEVICE_VENDOR := Luma Home
        DEVICE_MODEL := WRTQ-329ACN
        SOC := qcom-ipq4018
-       DEVICE_PACKAGES := ipq-wifi-luma_wrtq-329acn kmod-ath3k kmod-eeprom-at24 kmod-i2c-gpio
+       DEVICE_PACKAGES := kmod-ath3k kmod-eeprom-at24 kmod-i2c-gpio
        IMAGE_SIZE := 76632k
        BLOCKSIZE := 128k
        PAGESIZE := 2048
 endef
 TARGET_DEVICES += luma_wrtq-329acn
 
-define Device/meraki_mr33
+define Device/meraki_common
        $(call Device/FitImage)
        DEVICE_VENDOR := Cisco Meraki
-       DEVICE_MODEL := MR33
        SOC := qcom-ipq4029
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887-ct
+       DEVICE_DTS_LOADADDR := 0x89000000
+       DEVICE_PACKAGES := ath10k-firmware-qca9887-ct
+endef
+
+define Device/meraki_mr33
+       $(call Device/meraki_common)
+       DEVICE_MODEL := MR33
 endef
 TARGET_DEVICES += meraki_mr33
 
+define Device/meraki_mr74
+       $(call Device/meraki_common)
+       DEVICE_MODEL := MR74
+       DEVICE_DTS_CONFIG := config@3
+endef
+TARGET_DEVICES += meraki_mr74
+
 define Device/mobipromo_cm520-79f
        $(call Device/FitzImage)
        $(call Device/UbiFit)
@@ -695,7 +796,7 @@ define Device/mobipromo_cm520-79f
        SOC := qcom-ipq4019
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       DEVICE_PACKAGES := ipq-wifi-mobipromo_cm520-79f kmod-usb-ledtrig-usbport
+       DEVICE_PACKAGES := kmod-usb-ledtrig-usbport
 endef
 TARGET_DEVICES += mobipromo_cm520-79f
 
@@ -735,6 +836,30 @@ define Device/netgear_orbi
        DEVICE_PACKAGES := ath10k-firmware-qca9984-ct e2fsprogs kmod-fs-ext4 losetup
 endef
 
+define Device/netgear_rbx40
+       $(call Device/netgear_orbi)
+       NETGEAR_HW_ID := 29765515+0+4096+512+2x2+2x2+2x2
+       KERNEL_SIZE := 3932160
+       ROOTFS_SIZE := 32243712
+       IMAGE_SIZE := 36175872
+endef
+
+define Device/netgear_rbr40
+       $(call Device/netgear_rbx40)
+       DEVICE_MODEL := RBR40
+       DEVICE_VARIANT := v1
+       NETGEAR_BOARD_ID := RBR40
+endef
+TARGET_DEVICES += netgear_rbr40
+
+define Device/netgear_rbs40
+       $(call Device/netgear_rbx40)
+       DEVICE_MODEL := RBS40
+       DEVICE_VARIANT := v1
+       NETGEAR_BOARD_ID := RBS40
+endef
+TARGET_DEVICES += netgear_rbs40
+
 define Device/netgear_rbx50
        $(call Device/netgear_orbi)
        NETGEAR_HW_ID := 29765352+0+4000+512+2x2+2x2+4x4
@@ -790,8 +915,8 @@ define Device/netgear_wac510
        DEVICE_DTS_CONFIG := config@5
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       IMAGES += nand-factory.tar
-       IMAGE/nand-factory.tar := append-ubi | wac5xx-netgear-tar
+       IMAGES += factory.tar
+       IMAGE/factory.tar := append-ubi | wac5xx-netgear-tar
        DEVICE_PACKAGES := uboot-envtools
 endef
 TARGET_DEVICES += netgear_wac510
@@ -803,7 +928,7 @@ define Device/openmesh_a42
        SOC := qcom-ipq4018
        DEVICE_DTS_CONFIG := config@om.a42
        BLOCKSIZE := 64k
-       KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
+       KERNEL = kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
        IMAGE_SIZE := 15616k
        IMAGES += factory.bin
        IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=A42
@@ -818,7 +943,7 @@ define Device/openmesh_a62
        SOC := qcom-ipq4019
        DEVICE_DTS_CONFIG := config@om.a62
        BLOCKSIZE := 64k
-       KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
+       KERNEL = kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
        IMAGE_SIZE := 15552k
        IMAGES += factory.bin
        IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=A62
@@ -836,14 +961,13 @@ define Device/p2w_r619ac
        DEVICE_DTS_CONFIG := config@10
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       DEVICE_PACKAGES := ipq-wifi-p2w_r619ac
 endef
 
 define Device/p2w_r619ac-64m
        $(call Device/p2w_r619ac)
        DEVICE_VARIANT := 64M NAND
-       IMAGES += nand-factory.bin
-       IMAGE/nand-factory.bin := append-ubi | qsdk-ipq-factory-nand
+       IMAGES += factory.bin
+       IMAGE/factory.bin := append-ubi | qsdk-ipq-factory-nand
 endef
 TARGET_DEVICES += p2w_r619ac-64m
 
@@ -853,6 +977,18 @@ define Device/p2w_r619ac-128m
 endef
 TARGET_DEVICES += p2w_r619ac-128m
 
+define Device/pakedge_wr-1
+       $(call Device/FitImageLzma)
+       DEVICE_VENDOR := Pakedge
+       DEVICE_MODEL := WR-1
+       DEVICE_DTS_CONFIG := config@ap.dk01.1-c1
+       SOC := qcom-ipq4018
+       BLOCKSIZE := 64k
+       IMAGE_SIZE := 31232k
+       IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | append-metadata
+endef
+TARGET_DEVICES += pakedge_wr-1
+
 define Device/plasmacloud_pa1200
        $(call Device/FitImageLzma)
        DEVICE_VENDOR := Plasma Cloud
@@ -860,12 +996,11 @@ define Device/plasmacloud_pa1200
        SOC := qcom-ipq4018
        DEVICE_DTS_CONFIG := config@pc.pa1200
        BLOCKSIZE := 64k
-       KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
+       KERNEL = kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
        IMAGE_SIZE := 15616k
        IMAGES += factory.bin
        IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=PA1200
        IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
-       DEVICE_PACKAGES := ipq-wifi-plasmacloud_pa1200
 endef
 TARGET_DEVICES += plasmacloud_pa1200
 
@@ -876,48 +1011,15 @@ define Device/plasmacloud_pa2200
        SOC := qcom-ipq4019
        DEVICE_DTS_CONFIG := config@pc.pa2200
        BLOCKSIZE := 64k
-       KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
+       KERNEL = kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
        IMAGE_SIZE := 15552k
        IMAGES += factory.bin
        IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=PA2200
        IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
-       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-plasmacloud_pa2200
+       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct
 endef
 TARGET_DEVICES += plasmacloud_pa2200
 
-define Device/qcom_ap-dk01.1-c1
-       DEVICE_VENDOR := Qualcomm Atheros
-       DEVICE_MODEL := AP-DK01.1
-       DEVICE_VARIANT := C1
-       BOARD_NAME := ap-dk01.1-c1
-       SOC := qcom-ipq4019
-       DEVICE_DTS := qcom-ipq4019-ap.dk01.1-c1
-       KERNEL_INSTALL := 1
-       KERNEL_SIZE := 4096k
-       IMAGE_SIZE := 26624k
-       $(call Device/FitImage)
-       IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | append-metadata
-       DEFAULT := n
-endef
-TARGET_DEVICES += qcom_ap-dk01.1-c1
-
-define Device/qcom_ap-dk04.1-c1
-       $(call Device/FitImage)
-       $(call Device/UbiFit)
-       DEVICE_VENDOR := Qualcomm Atheros
-       DEVICE_MODEL := AP-DK04.1
-       DEVICE_VARIANT := C1
-       SOC := qcom-ipq4019
-       DEVICE_DTS := qcom-ipq4019-ap.dk04.1-c1
-       KERNEL_INSTALL := 1
-       KERNEL_SIZE := 4048k
-       BLOCKSIZE := 128k
-       PAGESIZE := 2048
-       BOARD_NAME := ap-dk04.1-c1
-       DEFAULT := n
-endef
-TARGET_DEVICES += qcom_ap-dk04.1-c1
-
 define Device/qxwlan_e2600ac-c1
        $(call Device/FitImage)
        DEVICE_VENDOR := Qxwlan
@@ -925,11 +1027,8 @@ define Device/qxwlan_e2600ac-c1
        DEVICE_VARIANT := C1
        BOARD_NAME := e2600ac-c1
        SOC := qcom-ipq4019
-       KERNEL_SIZE := 4096k
        IMAGE_SIZE := 31232k
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := ipq-wifi-qxwlan_e2600ac
-       DEFAULT := n
 endef
 TARGET_DEVICES += qxwlan_e2600ac-c1
 
@@ -943,10 +1042,21 @@ define Device/qxwlan_e2600ac-c2
        KERNEL_INSTALL := 1
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       DEVICE_PACKAGES := ipq-wifi-qxwlan_e2600ac
 endef
 TARGET_DEVICES += qxwlan_e2600ac-c2
 
+define Device/sony_ncp-hg100-cellular
+       $(call Device/FitImage)
+       DEVICE_VENDOR := Sony
+       DEVICE_MODEL := NCP-HG100/Cellular
+       DEVICE_DTS_CONFIG := config@ap.dk04.1-c4
+       SOC := qcom-ipq4019
+       KERNEL_SIZE := 8192k
+       IMAGE_SIZE := 128m
+       DEVICE_PACKAGES := e2fsprogs kmod-fs-ext4 uqmi
+endef
+TARGET_DEVICES += sony_ncp-hg100-cellular
+
 define Device/teltonika_rutx10
        $(call Device/FitImage)
        $(call Device/UbiFit)
@@ -958,10 +1068,41 @@ define Device/teltonika_rutx10
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        FILESYSTEMS := squashfs
-       IMAGE/nand-factory.ubi := append-ubi | qsdk-ipq-factory-nand | append-rutx-metadata
-       DEVICE_PACKAGES := ipq-wifi-teltonika_rutx kmod-bluetooth
+       IMAGE/factory.ubi := append-ubi | qsdk-ipq-factory-nand | append-rutx-metadata
+       DEVICE_PACKAGES := kmod-bluetooth
+endef
+# Missing DSA Setup
+#TARGET_DEVICES += teltonika_rutx10
+
+define Device/teltonika_rutx50
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_VENDOR := Teltonika
+       DEVICE_MODEL := RUTX50
+       SOC := qcom-ipq4018
+       DEVICE_DTS_CONFIG := config@5
+       KERNEL_INSTALL := 1
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       FILESYSTEMS := squashfs
+       IMAGE/factory.ubi := append-ubi
+       DEVICE_PACKAGES := ipq-wifi-teltonika_rutx kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
 endef
-TARGET_DEVICES += teltonika_rutx10
+TARGET_DEVICES += teltonika_rutx50
+
+define Device/tel_x1pro
+       $(call Device/FitImage)
+       DEVICE_VENDOR := Telco
+       DEVICE_MODEL := X1 Pro
+       SOC := qcom-ipq4019
+       KERNEL_SIZE := 4096k
+       IMAGE_SIZE := 31232k
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+       DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
+       DEFAULT := n
+endef
+# Missing DSA Setup
+#TARGET_DEVICES += tel_x1pro
 
 define Device/unielec_u4019-32m
        $(call Device/FitImage)
@@ -975,7 +1116,122 @@ define Device/unielec_u4019-32m
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
        DEFAULT := n
 endef
-TARGET_DEVICES += unielec_u4019-32m
+# Missing DSA Setup
+#TARGET_DEVICES += unielec_u4019-32m
+
+define Device/wallys_dr40x9
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_VENDOR := Wallys
+       DEVICE_MODEL := DR40X9
+       SOC := qcom-ipq40x9
+       DEVICE_DTS_CONFIG := config@ap.dk07.1-c1
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       DEVICE_PACKAGES := ipq-wifi-wallys_dr40x9
+endef
+TARGET_DEVICES += wallys_dr40x9
+
+define Device/yyets_le1
+       $(call Device/FitzImage)
+       DEVICE_VENDOR := YYeTs
+       DEVICE_MODEL := LE1
+       SOC := qcom-ipq4019
+       KERNEL_SIZE := 4096k
+       IMAGE_SIZE := 31232k
+       IMAGES += factory.bin
+       IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+       DEVICE_PACKAGES := ipq-wifi-yyets_le1 kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += yyets_le1
+
+define Device/zte_mf18a
+       $(call Device/FitImage)
+       DEVICE_VENDOR := ZTE
+       DEVICE_MODEL := MF18A
+       SOC := qcom-ipq4019
+       DEVICE_DTS_CONFIG := config@ap.dk04.1-c1
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       KERNEL_IN_UBI := 1
+       DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
+endef
+TARGET_DEVICES += zte_mf18a
+
+define Device/zte_mf28x_common
+       $(call Device/FitzImage)
+       DEVICE_VENDOR := ZTE
+       SOC := qcom-ipq4019
+       DEVICE_DTS_CONFIG := config@ap.dk04.1-c1
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       KERNEL_IN_UBI := 1
+       DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
+endef
+
+define Device/zte_mf282plus
+       $(call Device/zte_mf28x_common)
+       DEVICE_MODEL := MF282Plus
+#      The recovery image is used to return back to stock (an initramfs-based image
+#      that can be flashed to the device via sysupgrade
+#      The factory image is used to install from the stock firmware by using an
+#      exploit for the web interface
+       IMAGES += factory.bin recovery.bin
+       IMAGE/factory.bin  := append-ubi
+       IMAGE/recovery.bin := append-squashfs4-fakeroot | sysupgrade-tar kernel=$$$$(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE) rootfs=$$$$@ | append-metadata
+       DEVICE_PACKAGES := kmod-usb-acm kmod-usb-net-rndis
+endef
+TARGET_DEVICES += zte_mf282plus
+
+define Device/zte_mf286d
+       $(call Device/zte_mf28x_common)
+       DEVICE_MODEL := MF286D
+endef
+TARGET_DEVICES += zte_mf286d
+
+define Device/zte_mf287_common
+       $(call Device/zte_mf28x_common)
+       SOC := qcom-ipq4018
+#      The recovery image is used to return back to stock (an initramfs-based image
+#      that can be flashed to the device via sysupgrade
+#      The factory image is used to install from the stock firmware by using an
+#      exploit for the web interface
+       IMAGES += factory.bin recovery.bin
+       IMAGE/factory.bin  := append-ubi
+       IMAGE/recovery.bin := append-squashfs4-fakeroot | sysupgrade-tar kernel=$$$$(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE) rootfs=$$$$@ | append-metadata
+endef
+
+define Device/zte_mf287plus
+       $(call Device/zte_mf287_common)
+       DEVICE_PACKAGES += ipq-wifi-zte_mf287plus
+       DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
+       DEVICE_MODEL := MF287Plus
+endef
+TARGET_DEVICES += zte_mf287plus
+
+define Device/zte_mf287
+       $(call Device/zte_mf287_common)
+       DEVICE_PACKAGES += ipq-wifi-zte_mf287
+       DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
+       DEVICE_MODEL := MF287
+endef
+TARGET_DEVICES += zte_mf287
+
+define Device/zte_mf287pro
+       $(call Device/zte_mf287_common)
+       DEVICE_PACKAGES += ipq-wifi-zte_mf287plus
+       DEVICE_DTS_CONFIG := config@ap.dk04.1-c1
+       DEVICE_MODEL := MF287Pro
+endef
+TARGET_DEVICES += zte_mf287pro
+
+define Device/zte_mf289f
+       $(call Device/zte_mf28x_common)
+       DEVICE_MODEL := MF289F
+       DEVICE_PACKAGES += ipq-wifi-zte_mf289f ath10k-firmware-qca9984-ct
+endef
+TARGET_DEVICES += zte_mf289f
 
 define Device/zyxel_nbg6617
        $(call Device/FitImageLzma)
@@ -1009,4 +1265,5 @@ define Device/zyxel_wre6606
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size | append-metadata
        DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
 endef
-TARGET_DEVICES += zyxel_wre6606
+# Missing DSA Setup
+#TARGET_DEVICES += zyxel_wre6606