ipq40xx: meraki: remove swconfig in DEVICE_PACKAGES
[openwrt/staging/jow.git] / target / linux / ipq40xx / image / generic.mk
index 7c7a4acc5ca00266653fcc76dbbc9275a5b36aa3..78fa22c2345a09ce1d5338bf310d59a1adfa9232 100644 (file)
@@ -305,8 +305,7 @@ define Device/buffalo_wtr-m2133hp
        BLOCKSIZE := 128k
        PAGESIZE := 2048
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += buffalo_wtr-m2133hp
+TARGET_DEVICES += buffalo_wtr-m2133hp
 
 define Device/cellc_rtl30vw
        KERNEL_SUFFIX := -zImage.itb
@@ -757,26 +756,27 @@ define Device/luma_wrtq-329acn
 endef
 TARGET_DEVICES += luma_wrtq-329acn
 
-define Device/meraki_mr33
+define Device/meraki_common
        $(call Device/FitImage)
        DEVICE_VENDOR := Cisco Meraki
-       DEVICE_MODEL := MR33
        SOC := qcom-ipq4029
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887-ct
+       DEVICE_PACKAGES := ath10k-firmware-qca9887-ct
+endef
+
+define Device/meraki_mr33
+       $(call Device/meraki_common)
+       DEVICE_MODEL := MR33
+       DEFAULT := n
 endef
 TARGET_DEVICES += meraki_mr33
 
 define Device/meraki_mr74
-       $(call Device/FitImage)
-       DEVICE_VENDOR := Cisco Meraki
+       $(call Device/meraki_common)
        DEVICE_MODEL := MR74
-       SOC := qcom-ipq4029
-       BLOCKSIZE := 128k
-       PAGESIZE := 2048
-       DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887-ct
        DEVICE_DTS_CONFIG := config@3
+       DEFAULT := n
 endef
 TARGET_DEVICES += meraki_mr74
 
@@ -1075,6 +1075,22 @@ endef
 # Missing DSA Setup
 #TARGET_DEVICES += teltonika_rutx10
 
+define Device/teltonika_rutx50
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_VENDOR := Teltonika
+       DEVICE_MODEL := RUTX50
+       SOC := qcom-ipq4018
+       DEVICE_DTS_CONFIG := config@5
+       KERNEL_INSTALL := 1
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       FILESYSTEMS := squashfs
+       IMAGE/factory.ubi := append-ubi
+       DEVICE_PACKAGES := ipq-wifi-teltonika_rutx kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
+endef
+TARGET_DEVICES += teltonika_rutx50
+
 define Device/tel_x1pro
        $(call Device/FitImage)
        DEVICE_VENDOR := Telco
@@ -1147,10 +1163,28 @@ define Device/zte_mf286d
 endef
 TARGET_DEVICES += zte_mf286d
 
+define Device/zte_mf287plus
+       $(call Device/zte_mf28x_common)
+       DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
+       DEVICE_MODEL := MF287Plus
+       DEVICE_ALT0_VENDOR := ZTE
+       DEVICE_ALT0_MODEL := MF287
+       DEVICE_PACKAGES += ipq-wifi-zte_mf287plus
+       SOC := qcom-ipq4018
+#      The recovery image is used to return back to stock (an initramfs-based image
+#      that can be flashed to the device via sysupgrade
+#      The factory image is used to install from the stock firmware by using an
+#      exploit for the web interface
+       IMAGES += factory.bin recovery.bin
+       IMAGE/factory.bin  := append-ubi
+       IMAGE/recovery.bin := append-squashfs4-fakeroot | sysupgrade-tar kernel=$$$$(BIN_DIR)/openwrt-$$(BOARD)$$(if $$(SUBTARGET),-$$(SUBTARGET))-$$(DEVICE_NAME)-initramfs-zImage.itb rootfs=$$$$@ | append-metadata
+endef
+TARGET_DEVICES += zte_mf287plus
+
 define Device/zte_mf289f
        $(call Device/zte_mf28x_common)
        DEVICE_MODEL := MF289F
-       DEVICE_PACKAGES += ath10k-firmware-qca9984-ct
+       DEVICE_PACKAGES += ipq-wifi-zte_mf289f ath10k-firmware-qca9984-ct
 endef
 TARGET_DEVICES += zte_mf289f