ipq40xx: meraki: remove swconfig in DEVICE_PACKAGES
[openwrt/staging/jow.git] / target / linux / ipq40xx / image / generic.mk
index 1e5087bd24bf05a9409eb84b04dda6704a6d1c8d..78fa22c2345a09ce1d5338bf310d59a1adfa9232 100644 (file)
@@ -4,19 +4,19 @@ DEVICE_VARS += RAS_BOARD RAS_ROOTFS_SIZE RAS_VERSION
 DEVICE_VARS += WRGG_DEVNAME WRGG_SIGNATURE
 
 define Device/FitImage
-       KERNEL_SUFFIX := -fit-uImage.itb
+       KERNEL_SUFFIX := -uImage.itb
        KERNEL = kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
        KERNEL_NAME := Image
 endef
 
 define Device/FitImageLzma
-       KERNEL_SUFFIX := -fit-uImage.itb
+       KERNEL_SUFFIX := -uImage.itb
        KERNEL = kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(DEVICE_DTS).dtb
        KERNEL_NAME := Image
 endef
 
 define Device/FitzImage
-       KERNEL_SUFFIX := -fit-zImage.itb
+       KERNEL_SUFFIX := -zImage.itb
        KERNEL = kernel-bin | fit none $$(KDIR)/image-$$(DEVICE_DTS).dtb
        KERNEL_NAME := zImage
 endef
@@ -181,16 +181,14 @@ define Device/aruba_ap-303h
        $(call Device/aruba_glenmorangie)
        DEVICE_MODEL := AP-303H
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += aruba_ap-303h
+TARGET_DEVICES += aruba_ap-303h
 
 define Device/aruba_ap-365
        $(call Device/aruba_glenmorangie)
        DEVICE_MODEL := AP-365
-       DEVICE_PACKAGES := kmod-hwmon-ad7418 ipq-wifi-aruba_ap-365
+       DEVICE_PACKAGES := kmod-hwmon-ad7418
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += aruba_ap-365
+TARGET_DEVICES += aruba_ap-365
 
 define Device/asus_map-ac2200
        $(call Device/FitImageLzma)
@@ -275,7 +273,7 @@ define Device/avm_fritzbox-7530
        DEVICE_ALT0_VENDOR := AVM
        DEVICE_ALT0_MODEL := FRITZ!Box 7520
        SOC := qcom-ipq4019
-       DEVICE_PACKAGES := fritz-caldata fritz-tffs-nand
+       DEVICE_PACKAGES := fritz-caldata fritz-tffs-nand ltq-vdsl-vr11-app
 endef
 TARGET_DEVICES += avm_fritzbox-7530
 
@@ -295,8 +293,7 @@ define Device/avm_fritzrepeater-3000
        SOC := qcom-ipq4019
        DEVICE_PACKAGES := ath10k-firmware-qca9984-ct fritz-caldata fritz-tffs-nand
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += avm_fritzrepeater-3000
+TARGET_DEVICES += avm_fritzrepeater-3000
 
 define Device/buffalo_wtr-m2133hp
        $(call Device/FitImage)
@@ -308,11 +305,10 @@ define Device/buffalo_wtr-m2133hp
        BLOCKSIZE := 128k
        PAGESIZE := 2048
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += buffalo_wtr-m2133hp
+TARGET_DEVICES += buffalo_wtr-m2133hp
 
 define Device/cellc_rtl30vw
-       KERNEL_SUFFIX := -fit-zImage.itb
+       KERNEL_SUFFIX := -zImage.itb
        KERNEL_INITRAMFS = kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
        KERNEL = kernel-bin | fit none $$(KDIR)/image-$$(DEVICE_DTS).dtb | uImage lzma | pad-to 2048
        KERNEL_NAME := zImage
@@ -337,7 +333,7 @@ define Device/cilab_meshpoint-one
        $(call Device/8dev_jalapeno-common)
        DEVICE_VENDOR := Crisis Innovation Lab
        DEVICE_MODEL := MeshPoint.One
-       DEVICE_PACKAGES := kmod-i2c-gpio kmod-iio-bmp280-i2c kmod-hwmon-ina2xx kmod-rtc-pcf2127
+       DEVICE_PACKAGES += kmod-i2c-gpio kmod-iio-bmp280-i2c kmod-hwmon-ina2xx kmod-rtc-pcf2127
 endef
 # Missing DSA Setup
 #TARGET_DEVICES += cilab_meshpoint-one
@@ -389,7 +385,6 @@ define Device/devolo_magic-2-wifi-next
        IMAGE_SIZE := 26624k
        IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := ipq-wifi-devolo_magic-2-wifi-next
        DEFAULT := n
 endef
 # Missing DSA Setup
@@ -444,7 +439,7 @@ define Device/edgecore_oap100
        PAGESIZE := 2048
        IMAGES := sysupgrade.bin
        DEVICE_DTS_CONFIG := config@ap.dk07.1-c1
-       DEVICE_PACKAGES := ipq-wifi-edgecore_oap100 kmod-usb-acm kmod-usb-net kmod-usb-net-cdc-qmi uqmi
+       DEVICE_PACKAGES := kmod-usb-acm kmod-usb-net kmod-usb-net-cdc-qmi uqmi
 endef
 # Missing DSA Setup
 #TARGET_DEVICES += edgecore_oap100
@@ -541,10 +536,8 @@ define Device/extreme-networks_ws-ap3915i
        SOC := qcom-ipq4029
        BLOCKSIZE := 128k
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size | append-metadata
-       DEVICE_PACKAGES := ipq-wifi-extreme-networks_ws-ap3915i
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += extreme-networks_ws-ap3915i
+TARGET_DEVICES += extreme-networks_ws-ap3915i
 
 define Device/ezviz_cs-w3-wd1200g-eup
        $(call Device/FitImage)
@@ -561,8 +554,7 @@ define Device/ezviz_cs-w3-wd1200g-eup
        DEVICE_COMPAT_MESSAGE := uboot's bootcmd has to be updated (see wiki). \
                Upgrade via sysupgrade mechanism is not possible.
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += ezviz_cs-w3-wd1200g-eup
+TARGET_DEVICES += ezviz_cs-w3-wd1200g-eup
 
 define Device/glinet_gl-a1300
        $(call Device/FitImage)
@@ -574,7 +566,6 @@ define Device/glinet_gl-a1300
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        IMAGE_SIZE := 131072k
-       DEVICE_PACKAGE := ipq-wifi-glinet_gl-a1300
 endef
 TARGET_DEVICES += glinet_gl-a1300
 
@@ -589,10 +580,9 @@ define Device/glinet_gl-ap1300
        PAGESIZE := 2048
        IMAGE_SIZE := 131072k
        KERNEL_INSTALL := 1
-       DEVICE_PACKAGES := ipq-wifi-glinet_gl-ap1300 kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
+       DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += glinet_gl-ap1300
+TARGET_DEVICES += glinet_gl-ap1300
 
 define Device/glinet_gl-b1300
        $(call Device/FitzImage)
@@ -633,101 +623,126 @@ define Device/glinet_gl-s1300
        IMAGE_SIZE := 26624k
        IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := ipq-wifi-glinet_gl-s1300 kmod-fs-ext4 kmod-mmc kmod-spi-dev
+       DEVICE_PACKAGES := kmod-fs-ext4 kmod-mmc kmod-spi-dev
 endef
 # Missing DSA Setup
 #TARGET_DEVICES += glinet_gl-s1300
 
+define Device/kernel-size-6350-8300
+       DEVICE_COMPAT_VERSION := 2.0
+       DEVICE_COMPAT_MESSAGE := Kernel partition size must be increased for \
+       this OpenWrt version. Before continuing, you MUST issue either the \
+       command "fw_setenv kernsize 500000" from the OpenWrt command line, \
+       or "setenv kernsize 500000 ; saveenv" from the U-Boot serial console. \
+       Instead of the sysupgrade image, you must then install the OpenWrt \
+       factory image, setting the force flag and wiping the configuration. \
+       (e.g. "sysupgrade -n -F openwrt-squashfs-factory.bin" on command line)
+endef
+
 define Device/linksys_ea6350v3
        # The Linksys EA6350v3 has a uboot bootloader that does not
        # support either booting lzma kernel images nor booting UBI
        # partitions. This uboot, however, supports raw kernel images and
        # gzipped images.
        #
-       # As for the time of writing this, the device will boot the kernel
-       # from a fixed address with a fixed length of 3MiB. Also, the
-       # device has a hard-coded kernel command line that requieres the
+       # As configured by the OEM factory, the device will boot the kernel
+       # from a fixed address with a fixed length of 3 MiB. Also, the
+       # device has a hard-coded kernel command line that requires the
        # rootfs and alt_rootfs to be in mtd11 and mtd13 respectively.
        # Oh... and the kernel partition overlaps with the rootfs
        # partition (the same for alt_kernel and alt_rootfs).
        #
        # If you are planing re-partitioning the device, you may want to
-       # keep those details in mind:
-       # 1. The kernel adresses you should honor are 0x00000000 and
+       # keep these details in mind:
+       # 1. The kernel addresses you should honor are 0x00000000 and
        #    0x02800000 respectively.
-       # 2. The kernel size (plus the dtb) cannot exceed 3.00MiB in size.
+       # 2. The kernel size (plus the dtb) cannot exceed 3 MiB in size
+       #    unless the uboot environment variable "kernsize" is increased.
        # 3. You can use 'zImage', but not a raw 'Image' packed with lzma.
        # 4. The kernel command line from uboot is harcoded to boot with
        #    rootfs either in mtd11 or mtd13.
        $(call Device/FitzImage)
+       $(call Device/kernel-size-6350-8300)
        DEVICE_VENDOR := Linksys
        DEVICE_MODEL := EA6350
        DEVICE_VARIANT := v3
        SOC := qcom-ipq4018
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       KERNEL_SIZE := 3072k
-       IMAGE_SIZE := 37888k
+       KERNEL_SIZE := 5120k
+       IMAGE_SIZE := 35840k
        UBINIZE_OPTS := -E 5
        IMAGES += factory.bin
        IMAGE/factory.bin := append-kernel | append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=EA6350v3
-       DEFAULT := n
 endef
 TARGET_DEVICES += linksys_ea6350v3
 
 define Device/linksys_ea8300
        $(call Device/FitzImage)
+       $(call Device/kernel-size-6350-8300)
        DEVICE_VENDOR := Linksys
        DEVICE_MODEL := EA8300
        SOC := qcom-ipq4019
-       KERNEL_SIZE := 3072k
-       IMAGE_SIZE := 87040k
+       KERNEL_SIZE := 5120k
+       IMAGE_SIZE := 84992k
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        UBINIZE_OPTS := -E 5    # EOD marks to "hide" factory sig at EOF
        IMAGES += factory.bin
        IMAGE/factory.bin  := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=EA8300
-       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-linksys_ea8300 kmod-usb-ledtrig-usbport
-       DEFAULT := n
+       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct kmod-usb-ledtrig-usbport
 endef
 TARGET_DEVICES += linksys_ea8300
 
 define Device/linksys_mr8300
        $(call Device/FitzImage)
+       $(call Device/kernel-size-6350-8300)
        DEVICE_VENDOR := Linksys
        DEVICE_MODEL := MR8300
        SOC := qcom-ipq4019
-       KERNEL_SIZE := 3072k
-       IMAGE_SIZE := 87040k
+       KERNEL_SIZE := 5120k
+       IMAGE_SIZE := 84992k
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        UBINIZE_OPTS := -E 5    # EOD marks to "hide" factory sig at EOF
        IMAGES += factory.bin
        IMAGE/factory.bin  := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=MR8300
        DEVICE_PACKAGES := ath10k-firmware-qca9888-ct kmod-usb-ledtrig-usbport
-       DEFAULT := n
 endef
 TARGET_DEVICES += linksys_mr8300
 
-define Device/linksys_whw01-v1
+define Device/linksys_whw03v2
+       $(call Device/FitzImage)
+       DEVICE_VENDOR := Linksys
+       DEVICE_MODEL := WHW03
+       DEVICE_VARIANT := V2
+       SOC := qcom-ipq4019
+       KERNEL_SIZE := 6144k
+       IMAGE_SIZE := 158720k
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       UBINIZE_OPTS := -E 5    # EOD marks to "hide" factory sig at EOF
+       IMAGES += factory.bin
+       IMAGE/factory.bin  := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=WHW03v2
+       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct kmod-leds-pca963x kmod-spi-dev kmod-bluetooth
+endef
+TARGET_DEVICES += linksys_whw03v2
+
+define Device/linksys_whw01
        $(call Device/FitzImage)
        DEVICE_VENDOR := Linksys
        DEVICE_MODEL := WHW01
-       DEVICE_VARIANT := v1
        KERNEL_SIZE := 6144k
-       IMAGE_SIZE := 28704512  # 28032k minus linksys signature (256-bytes).
+       IMAGE_SIZE := 75776K
        SOC := qcom-ipq4018
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        UBINIZE_OPTS := -E 5    # EOD marks to "hide" factory sig at EOF
        IMAGES += factory.bin
-       IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | \
-               append-ubi | linksys-image type=WHW01 | pad-to $$$$(PAGESIZE) | \
-               check-size
+       IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=WHW01
        DEVICE_PACKAGES := uboot-envtools kmod-leds-pca963x
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += linksys_whw01-v1
+TARGET_DEVICES += linksys_whw01
 
 define Device/luma_wrtq-329acn
        $(call Device/FitImage)
@@ -741,26 +756,27 @@ define Device/luma_wrtq-329acn
 endef
 TARGET_DEVICES += luma_wrtq-329acn
 
-define Device/meraki_mr33
+define Device/meraki_common
        $(call Device/FitImage)
        DEVICE_VENDOR := Cisco Meraki
-       DEVICE_MODEL := MR33
        SOC := qcom-ipq4029
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887-ct
+       DEVICE_PACKAGES := ath10k-firmware-qca9887-ct
+endef
+
+define Device/meraki_mr33
+       $(call Device/meraki_common)
+       DEVICE_MODEL := MR33
+       DEFAULT := n
 endef
 TARGET_DEVICES += meraki_mr33
 
 define Device/meraki_mr74
-       $(call Device/FitImage)
-       DEVICE_VENDOR := Cisco Meraki
+       $(call Device/meraki_common)
        DEVICE_MODEL := MR74
-       SOC := qcom-ipq4029
-       BLOCKSIZE := 128k
-       PAGESIZE := 2048
-       DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887-ct
        DEVICE_DTS_CONFIG := config@3
+       DEFAULT := n
 endef
 TARGET_DEVICES += meraki_mr74
 
@@ -791,16 +807,14 @@ define Device/netgear_ex6100v2
        DEVICE_MODEL := EX6100
        DEVICE_VARIANT := v2
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += netgear_ex6100v2
+TARGET_DEVICES += netgear_ex6100v2
 
 define Device/netgear_ex6150v2
        $(call Device/netgear_ex61x0v2)
        DEVICE_MODEL := EX6150
        DEVICE_VARIANT := v2
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += netgear_ex6150v2
+TARGET_DEVICES += netgear_ex6150v2
 
 define Device/netgear_orbi
        $(call Device/DniImage)
@@ -915,7 +929,6 @@ define Device/p2w_r619ac
        DEVICE_DTS_CONFIG := config@10
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       DEVICE_PACKAGES := ipq-wifi-p2w_r619ac
 endef
 
 define Device/p2w_r619ac-64m
@@ -937,7 +950,6 @@ define Device/pakedge_wr-1
        DEVICE_VENDOR := Pakedge
        DEVICE_MODEL := WR-1
        DEVICE_DTS_CONFIG := config@ap.dk01.1-c1
-       DEVICE_PACKAGES := ipq-wifi-pakedge_wr-1
        SOC := qcom-ipq4018
        BLOCKSIZE := 64k
        IMAGE_SIZE := 31232k
@@ -1016,14 +1028,10 @@ define Device/qxwlan_e2600ac-c1
        DEVICE_VARIANT := C1
        BOARD_NAME := e2600ac-c1
        SOC := qcom-ipq4019
-       KERNEL_SIZE := 4096k
        IMAGE_SIZE := 31232k
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := ipq-wifi-qxwlan_e2600ac-c1
-       DEFAULT := n
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += qxwlan_e2600ac-c1
+TARGET_DEVICES += qxwlan_e2600ac-c1
 
 define Device/qxwlan_e2600ac-c2
        $(call Device/FitImage)
@@ -1035,10 +1043,8 @@ define Device/qxwlan_e2600ac-c2
        KERNEL_INSTALL := 1
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       DEVICE_PACKAGES := ipq-wifi-qxwlan_e2600ac-c2
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += qxwlan_e2600ac-c2
+TARGET_DEVICES += qxwlan_e2600ac-c2
 
 define Device/sony_ncp-hg100-cellular
        $(call Device/FitImage)
@@ -1048,8 +1054,7 @@ define Device/sony_ncp-hg100-cellular
        SOC := qcom-ipq4019
        KERNEL_SIZE := 8192k
        IMAGE_SIZE := 128m
-       DEVICE_PACKAGES := e2fsprogs ipq-wifi-sony_ncp-hg100-cellular \
-               kmod-fs-ext4 uqmi
+       DEVICE_PACKAGES := e2fsprogs kmod-fs-ext4 uqmi
 endef
 TARGET_DEVICES += sony_ncp-hg100-cellular
 
@@ -1065,11 +1070,27 @@ define Device/teltonika_rutx10
        PAGESIZE := 2048
        FILESYSTEMS := squashfs
        IMAGE/factory.ubi := append-ubi | qsdk-ipq-factory-nand | append-rutx-metadata
-       DEVICE_PACKAGES := ipq-wifi-teltonika_rutx kmod-bluetooth
+       DEVICE_PACKAGES := kmod-bluetooth
 endef
 # Missing DSA Setup
 #TARGET_DEVICES += teltonika_rutx10
 
+define Device/teltonika_rutx50
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_VENDOR := Teltonika
+       DEVICE_MODEL := RUTX50
+       SOC := qcom-ipq4018
+       DEVICE_DTS_CONFIG := config@5
+       KERNEL_INSTALL := 1
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       FILESYSTEMS := squashfs
+       IMAGE/factory.ubi := append-ubi
+       DEVICE_PACKAGES := ipq-wifi-teltonika_rutx kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
+endef
+TARGET_DEVICES += teltonika_rutx50
+
 define Device/tel_x1pro
        $(call Device/FitImage)
        DEVICE_VENDOR := Telco
@@ -1099,6 +1120,32 @@ endef
 # Missing DSA Setup
 #TARGET_DEVICES += unielec_u4019-32m
 
+define Device/wallys_dr40x9
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_VENDOR := Wallys
+       DEVICE_MODEL := DR40X9
+       SOC := qcom-ipq40x9
+       DEVICE_DTS_CONFIG := config@ap.dk07.1-c1
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       DEVICE_PACKAGES := ipq-wifi-wallys_dr40x9
+endef
+TARGET_DEVICES += wallys_dr40x9
+
+define Device/zte_mf18a
+       $(call Device/FitImage)
+       DEVICE_VENDOR := ZTE
+       DEVICE_MODEL := MF18A
+       SOC := qcom-ipq4019
+       DEVICE_DTS_CONFIG := config@ap.dk04.1-c1
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       KERNEL_IN_UBI := 1
+       DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
+endef
+TARGET_DEVICES += zte_mf18a
+
 define Device/zte_mf28x_common
        $(call Device/FitzImage)
        DEVICE_VENDOR := ZTE
@@ -1116,6 +1163,24 @@ define Device/zte_mf286d
 endef
 TARGET_DEVICES += zte_mf286d
 
+define Device/zte_mf287plus
+       $(call Device/zte_mf28x_common)
+       DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
+       DEVICE_MODEL := MF287Plus
+       DEVICE_ALT0_VENDOR := ZTE
+       DEVICE_ALT0_MODEL := MF287
+       DEVICE_PACKAGES += ipq-wifi-zte_mf287plus
+       SOC := qcom-ipq4018
+#      The recovery image is used to return back to stock (an initramfs-based image
+#      that can be flashed to the device via sysupgrade
+#      The factory image is used to install from the stock firmware by using an
+#      exploit for the web interface
+       IMAGES += factory.bin recovery.bin
+       IMAGE/factory.bin  := append-ubi
+       IMAGE/recovery.bin := append-squashfs4-fakeroot | sysupgrade-tar kernel=$$$$(BIN_DIR)/openwrt-$$(BOARD)$$(if $$(SUBTARGET),-$$(SUBTARGET))-$$(DEVICE_NAME)-initramfs-zImage.itb rootfs=$$$$@ | append-metadata
+endef
+TARGET_DEVICES += zte_mf287plus
+
 define Device/zte_mf289f
        $(call Device/zte_mf28x_common)
        DEVICE_MODEL := MF289F