ipq40xx: add support for Wallystech DR40x9
[openwrt/staging/dedeckeh.git] / target / linux / ipq40xx / image / generic.mk
index e17db37d8205de0499bb50ec2b04edc09116ff84..48514b88416275a05d831825a8a9eb2b4ef73c65 100644 (file)
@@ -132,6 +132,7 @@ define Device/8dev_habanero-dvk
        IMAGE_SIZE := 30976k
        SOC := qcom-ipq4019
        IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | check-size | append-metadata
+       DEVICE_PACKAGES := ipq-wifi-8dev_habanero
 endef
 TARGET_DEVICES += 8dev_habanero-dvk
 
@@ -141,6 +142,7 @@ define Device/8dev_jalapeno-common
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        SOC := qcom-ipq4018
+       DEVICE_PACKAGES := ipq-wifi-8dev_jalapeno
 endef
 
 define Device/8dev_jalapeno
@@ -274,7 +276,7 @@ define Device/avm_fritzbox-7530
        DEVICE_ALT0_VENDOR := AVM
        DEVICE_ALT0_MODEL := FRITZ!Box 7520
        SOC := qcom-ipq4019
-       DEVICE_PACKAGES := fritz-caldata fritz-tffs-nand
+       DEVICE_PACKAGES := fritz-caldata fritz-tffs-nand ltq-vdsl-vr11-app
 endef
 TARGET_DEVICES += avm_fritzbox-7530
 
@@ -336,7 +338,7 @@ define Device/cilab_meshpoint-one
        $(call Device/8dev_jalapeno-common)
        DEVICE_VENDOR := Crisis Innovation Lab
        DEVICE_MODEL := MeshPoint.One
-       DEVICE_PACKAGES := kmod-i2c-gpio kmod-iio-bmp280-i2c kmod-hwmon-ina2xx kmod-rtc-pcf2127
+       DEVICE_PACKAGES += kmod-i2c-gpio kmod-iio-bmp280-i2c kmod-hwmon-ina2xx kmod-rtc-pcf2127
 endef
 # Missing DSA Setup
 #TARGET_DEVICES += cilab_meshpoint-one
@@ -542,8 +544,7 @@ define Device/extreme-networks_ws-ap3915i
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size | append-metadata
        DEVICE_PACKAGES := ipq-wifi-extreme-networks_ws-ap3915i
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += extreme-networks_ws-ap3915i
+TARGET_DEVICES += extreme-networks_ws-ap3915i
 
 define Device/ezviz_cs-w3-wd1200g-eup
        $(call Device/FitImage)
@@ -720,25 +721,38 @@ define Device/linksys_mr8300
 endef
 TARGET_DEVICES += linksys_mr8300
 
-define Device/linksys_whw01-v1
+define Device/linksys_whw03v2
+       $(call Device/FitzImage)
+       DEVICE_VENDOR := Linksys
+       DEVICE_MODEL := WHW03
+       DEVICE_VARIANT := V2
+       SOC := qcom-ipq4019
+       KERNEL_SIZE := 6144k
+       IMAGE_SIZE := 158720k
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       UBINIZE_OPTS := -E 5    # EOD marks to "hide" factory sig at EOF
+       IMAGES += factory.bin
+       IMAGE/factory.bin  := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=WHW03v2
+       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-linksys_whw03v2 kmod-leds-pca963x kmod-spi-dev kmod-bluetooth
+endef
+TARGET_DEVICES += linksys_whw03v2
+
+define Device/linksys_whw01
        $(call Device/FitzImage)
        DEVICE_VENDOR := Linksys
        DEVICE_MODEL := WHW01
-       DEVICE_VARIANT := v1
        KERNEL_SIZE := 6144k
-       IMAGE_SIZE := 28704512  # 28032k minus linksys signature (256-bytes).
+       IMAGE_SIZE := 75776K
        SOC := qcom-ipq4018
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        UBINIZE_OPTS := -E 5    # EOD marks to "hide" factory sig at EOF
        IMAGES += factory.bin
-       IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | \
-               append-ubi | linksys-image type=WHW01 | pad-to $$$$(PAGESIZE) | \
-               check-size
+       IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=WHW01
        DEVICE_PACKAGES := uboot-envtools kmod-leds-pca963x
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += linksys_whw01-v1
+TARGET_DEVICES += linksys_whw01
 
 define Device/luma_wrtq-329acn
        $(call Device/FitImage)
@@ -802,16 +816,14 @@ define Device/netgear_ex6100v2
        DEVICE_MODEL := EX6100
        DEVICE_VARIANT := v2
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += netgear_ex6100v2
+TARGET_DEVICES += netgear_ex6100v2
 
 define Device/netgear_ex6150v2
        $(call Device/netgear_ex61x0v2)
        DEVICE_MODEL := EX6150
        DEVICE_VARIANT := v2
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += netgear_ex6150v2
+TARGET_DEVICES += netgear_ex6150v2
 
 define Device/netgear_orbi
        $(call Device/DniImage)
@@ -1110,6 +1122,32 @@ endef
 # Missing DSA Setup
 #TARGET_DEVICES += unielec_u4019-32m
 
+define Device/wallys_dr40x9
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_VENDOR := Wallys
+       DEVICE_MODEL := DR40X9
+       SOC := qcom-ipq40x9
+       DEVICE_DTS_CONFIG := config@ap.dk07.1-c1
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       DEVICE_PACKAGES := ipq-wifi-wallys_dr40x9
+endef
+TARGET_DEVICES += wallys_dr40x9
+
+define Device/zte_mf18a
+       $(call Device/FitImage)
+       DEVICE_VENDOR := ZTE
+       DEVICE_MODEL := MF18A
+       SOC := qcom-ipq4019
+       DEVICE_DTS_CONFIG := config@ap.dk04.1-c1
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       KERNEL_IN_UBI := 1
+       DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct ipq-wifi-zte_mf18a
+endef
+TARGET_DEVICES += zte_mf18a
+
 define Device/zte_mf28x_common
        $(call Device/FitzImage)
        DEVICE_VENDOR := ZTE