Revert "ipq-wifi: fix upstream board-2.bin ZTE M289F snafu"
[openwrt/staging/pepe2k.git] / target / linux / ipq40xx / image / generic.mk
index 15f48a67b255cbfa399b9e0bc8798d2dbcbc54df..3b6d1119053c6bec7c4ac629aaedd6eb3b6eab30 100644 (file)
@@ -68,7 +68,7 @@ define Build/mkmylofw_32m
 
        let \
                size="$$(stat -c%s $@)" \
-               pad="$(subst k,* 1024,$(BLOCKSIZE))" \
+               pad="$(call exp_units,$(BLOCKSIZE))" \
                pad="(pad - (size % pad)) % pad" \
                newsize='size + pad'; \
                $(STAGING_DIR_HOST)/bin/mkmylofw \
@@ -354,7 +354,7 @@ endef
 #TARGET_DEVICES += compex_wpj419
 
 define Device/compex_wpj428
-       $(call Device/FitImage)
+       $(call Device/FitzImage)
        DEVICE_VENDOR := Compex
        DEVICE_MODEL := WPJ428
        SOC := qcom-ipq4028
@@ -538,6 +538,16 @@ define Device/extreme-networks_ws-ap3915i
 endef
 TARGET_DEVICES += extreme-networks_ws-ap3915i
 
+define Device/extreme-networks_ws-ap391x
+       $(call Device/FitImage)
+       DEVICE_VENDOR := Extreme Networks
+       DEVICE_MODEL := WS-AP391x
+       IMAGE_SIZE := 15040k
+       SOC := qcom-ipq4029
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size | append-metadata
+endef
+TARGET_DEVICES += extreme-networks_ws-ap391x
+
 define Device/ezviz_cs-w3-wd1200g-eup
        $(call Device/FitImage)
        DEVICE_VENDOR := EZVIZ
@@ -670,6 +680,7 @@ define Device/linksys_ea6350v3
        PAGESIZE := 2048
        KERNEL_SIZE := 5120k
        IMAGE_SIZE := 35840k
+       NAND_SIZE := 128m
        UBINIZE_OPTS := -E 5
        IMAGES += factory.bin
        IMAGE/factory.bin := append-kernel | append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=EA6350v3
@@ -684,6 +695,7 @@ define Device/linksys_ea8300
        SOC := qcom-ipq4019
        KERNEL_SIZE := 5120k
        IMAGE_SIZE := 84992k
+       NAND_SIZE := 256m
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        UBINIZE_OPTS := -E 5    # EOD marks to "hide" factory sig at EOF
@@ -701,6 +713,7 @@ define Device/linksys_mr8300
        SOC := qcom-ipq4019
        KERNEL_SIZE := 5120k
        IMAGE_SIZE := 84992k
+       NAND_SIZE := 256m
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        UBINIZE_OPTS := -E 5    # EOD marks to "hide" factory sig at EOF
@@ -718,6 +731,7 @@ define Device/linksys_whw03v2
        SOC := qcom-ipq4019
        KERNEL_SIZE := 6144k
        IMAGE_SIZE := 158720k
+       NAND_SIZE := 512m
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        UBINIZE_OPTS := -E 5    # EOD marks to "hide" factory sig at EOF
@@ -732,7 +746,8 @@ define Device/linksys_whw01
        DEVICE_VENDOR := Linksys
        DEVICE_MODEL := WHW01
        KERNEL_SIZE := 6144k
-       IMAGE_SIZE := 75776K
+       IMAGE_SIZE := 75776k
+       NAND_SIZE := 256m
        SOC := qcom-ipq4018
        BLOCKSIZE := 128k
        PAGESIZE := 2048
@@ -826,6 +841,49 @@ define Device/netgear_orbi
        DEVICE_PACKAGES := ath10k-firmware-qca9984-ct e2fsprogs kmod-fs-ext4 losetup
 endef
 
+define Device/netgear_lbr20
+       $(call Device/netgear_orbi)
+       DEVICE_MODEL := LBR20
+       NETGEAR_BOARD_ID := LBR20
+       NETGEAR_HW_ID := 29766182+0+256+512+2x2+2x2+2x2+1
+       KERNEL_SIZE := 7340032
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       UBINIZE_OPTS := -E 5
+       IMAGE/factory.img := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
+               append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | \
+               append-ubi | netgear-dni
+       IMAGE/sysupgrade.bin := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
+               append-uImage-fakehdr filesystem | sysupgrade-tar kernel=$$$$@ | \
+               append-metadata
+       DEVICE_PACKAGES := ipq-wifi-netgear_lbr20 ath10k-firmware-qca9888-ct kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
+endef
+TARGET_DEVICES += netgear_lbr20
+
+define Device/netgear_rbx40
+       $(call Device/netgear_orbi)
+       NETGEAR_HW_ID := 29765515+0+4096+512+2x2+2x2+2x2
+       KERNEL_SIZE := 3932160
+       ROOTFS_SIZE := 32243712
+       IMAGE_SIZE := 36175872
+endef
+
+define Device/netgear_rbr40
+       $(call Device/netgear_rbx40)
+       DEVICE_MODEL := RBR40
+       DEVICE_VARIANT := v1
+       NETGEAR_BOARD_ID := RBR40
+endef
+TARGET_DEVICES += netgear_rbr40
+
+define Device/netgear_rbs40
+       $(call Device/netgear_rbx40)
+       DEVICE_MODEL := RBS40
+       DEVICE_VARIANT := v1
+       NETGEAR_BOARD_ID := RBS40
+endef
+TARGET_DEVICES += netgear_rbs40
+
 define Device/netgear_rbx50
        $(call Device/netgear_orbi)
        NETGEAR_HW_ID := 29765352+0+4000+512+2x2+2x2+4x4
@@ -1098,6 +1156,20 @@ define Device/wallys_dr40x9
 endef
 TARGET_DEVICES += wallys_dr40x9
 
+define Device/yyets_le1
+       $(call Device/FitzImage)
+       DEVICE_VENDOR := YYeTs
+       DEVICE_MODEL := LE1
+       SOC := qcom-ipq4019
+       KERNEL_SIZE := 4096k
+       IMAGE_SIZE := 31232k
+       IMAGES += factory.bin
+       IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+       DEVICE_PACKAGES := ipq-wifi-yyets_le1 kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += yyets_le1
+
 define Device/zte_mf18a
        $(call Device/FitImage)
        DEVICE_VENDOR := ZTE
@@ -1122,6 +1194,20 @@ define Device/zte_mf28x_common
        DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
 endef
 
+define Device/zte_mf282plus
+       $(call Device/zte_mf28x_common)
+       DEVICE_MODEL := MF282Plus
+#      The recovery image is used to return back to stock (an initramfs-based image
+#      that can be flashed to the device via sysupgrade
+#      The factory image is used to install from the stock firmware by using an
+#      exploit for the web interface
+       IMAGES += factory.bin recovery.bin
+       IMAGE/factory.bin  := append-ubi
+       IMAGE/recovery.bin := append-squashfs4-fakeroot | sysupgrade-tar kernel=$$$$(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE) rootfs=$$$$@ | append-metadata
+       DEVICE_PACKAGES := kmod-usb-acm kmod-usb-net-rndis
+endef
+TARGET_DEVICES += zte_mf282plus
+
 define Device/zte_mf286d
        $(call Device/zte_mf28x_common)
        DEVICE_MODEL := MF286D
@@ -1130,7 +1216,6 @@ TARGET_DEVICES += zte_mf286d
 
 define Device/zte_mf287_common
        $(call Device/zte_mf28x_common)
-       DEVICE_PACKAGES += ipq-wifi-zte_mf287plus
        SOC := qcom-ipq4018
 #      The recovery image is used to return back to stock (an initramfs-based image
 #      that can be flashed to the device via sysupgrade
@@ -1138,20 +1223,28 @@ define Device/zte_mf287_common
 #      exploit for the web interface
        IMAGES += factory.bin recovery.bin
        IMAGE/factory.bin  := append-ubi
-       IMAGE/recovery.bin := append-squashfs4-fakeroot | sysupgrade-tar kernel=$$$$(BIN_DIR)/openwrt-$$(BOARD)$$(if $$(SUBTARGET),-$$(SUBTARGET))-$$(DEVICE_NAME)-initramfs-zImage.itb rootfs=$$$$@ | append-metadata
+       IMAGE/recovery.bin := append-squashfs4-fakeroot | sysupgrade-tar kernel=$$$$(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE) rootfs=$$$$@ | append-metadata
 endef
 
 define Device/zte_mf287plus
        $(call Device/zte_mf287_common)
+       DEVICE_PACKAGES += ipq-wifi-zte_mf287plus
        DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
        DEVICE_MODEL := MF287Plus
-       DEVICE_ALT0_VENDOR := ZTE
-       DEVICE_ALT0_MODEL := MF287
 endef
 TARGET_DEVICES += zte_mf287plus
 
+define Device/zte_mf287
+       $(call Device/zte_mf287_common)
+       DEVICE_PACKAGES += ipq-wifi-zte_mf287
+       DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
+       DEVICE_MODEL := MF287
+endef
+TARGET_DEVICES += zte_mf287
+
 define Device/zte_mf287pro
        $(call Device/zte_mf287_common)
+       DEVICE_PACKAGES += ipq-wifi-zte_mf287plus
        DEVICE_DTS_CONFIG := config@ap.dk04.1-c1
        DEVICE_MODEL := MF287Pro
 endef
@@ -1160,7 +1253,7 @@ TARGET_DEVICES += zte_mf287pro
 define Device/zte_mf289f
        $(call Device/zte_mf28x_common)
        DEVICE_MODEL := MF289F
-       DEVICE_PACKAGES += ipq-wifi-zte_mf289f ath10k-firmware-qca9984-ct
+       DEVICE_PACKAGES += ath10k-firmware-qca9984-ct
 endef
 TARGET_DEVICES += zte_mf289f