linux/3.3: build mdio_register_board_info into the kernel if PHYLIB is selected
[openwrt/openwrt.git] / target / linux / generic / patches-3.3 / 727-phy-rtl8367.patch
index 820bda0cdb207a06173235967163490c95979ebc..ca8ccdf6131daee42391b175330425323fc4d052 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -179,6 +179,10 @@ config RTL8366RB_PHY
+@@ -183,6 +183,10 @@ config RTL8366RB_PHY
        tristate "Driver for the Realtek RTL8366RB switch"
        select SWCONFIG
  
@@ -13,7 +13,7 @@
        depends on RTL8366S_PHY || RTL8366RB_PHY
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -23,6 +23,7 @@ obj-$(CONFIG_RTL8306_PHY)    += rtl8306.o
+@@ -25,6 +25,7 @@ obj-$(CONFIG_RTL8306_PHY)    += rtl8306.o
  obj-$(CONFIG_RTL8366_SMI)     += rtl8366_smi.o
  obj-$(CONFIG_RTL8366S_PHY)    += rtl8366s.o
  obj-$(CONFIG_RTL8366RB_PHY)   += rtl8366rb.o